CERBOT: Challenge failed for domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cloud.ksbt-progweb.space

I ran this command: sudo certbot --apache

It produced this output:

My web server is (include version):Ubuntu Server 20.4 LTS

The operating system my web server runs on is (include version): Virtual Machine Ubuntu Server 20.4 LTS

My hosting provider, if applicable, is:

DNS: hover.com
Droplet : DigitalOcean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): cerbot --apache

1 Like

Did you already manage to sort this out?

Based on the error message it looks like you needed to open port 80 on your DigitalOcean droplet. It looks like you've already done that though!

3 Likes

I solved it! :grinning:
Problems: ufw was not enabled. I had not opened ports 22 and 80. Fix it using:

sudo ufw enable

Rule to use ssh and no locking my self out of the server:
sudo ufw 22/tcp

Rule to allow viewing the website from anywhere in this case:
sudo ufw 80/tcp

And giving APACHE permissions:

sudo ufw allow 'Apache Full'
sudo ufw delete allow 'Apache'

Simpler than what I've thought :rofl:

2 Likes