I can't setup SSL for my domain (sexychip.com)


#1

My domain is:sexychip.com

I ran this command:./certbot-auto certonly --standalone

It produced this output: sexychip.com: Non-ASCII domain names not supported. To issue for an
Internationalized Domain Name, use Punycode.
Maybe have sex letter in the my domain, but site content not about sex, it’s site sale underwear
Help me, Please!


#2

Hi,

Can you check your input method and see if that’s non English input?

(When I’m using Chinese input at command line, it gave me the same error)

Thank you


#3

Thank very very much.


#4

Hi @thuan79,

Was this the full command you ran? It seems like its missing the domain arguments.


#5

thank you @cpu. @stevenzhu have help me soleved problem


#6

Glad to hear it. Thanks @stevenzhu!


#7

I think the main issue is

When he didn’t specify certonly with -d, he was instructed to enter it in the interactive responses.
Which caused this issue.

@thuan79 :grinning: glad to help


#8

@stevenzhu, do you happen to understand how this happens? If you run hexdump -d and type an ASCII domain name in using the Chinese input method, do you see some other Unicode values in the output like a byte order mark or something?


#9

For Chinese input, it’s either going to have ' or some Chinese characters (since Chinese use pinyin, which also can be used in regular keyboard.)


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.