Certbot 0.19.0 issue with IDN domain

Hello,

I’m trying to generate a certificate for a website, usually it works fine, but this site include ī as part of its name, so when I try to run certbot I get:

Non-ASCII domain names not supported. To issue for an Internationalized Domain Name, use Punycode.

From what I have checked here I need to have at least version 0.10.0 for IDN support, so I checked and I got the latest version of certbot:

/usr/local/certbot/certbot-auto --version

certbot 0.19.0

But I still get the same error when I run certbot.

Any suggestion on what I could do ?

Thanks

I believe that the IDN support was added after 0.10.0 in the form of accepting punycode.:

Since version 0.10.0, Certbot supports requesting IDNs as long as they are given to Certbot as punycode.

You will need to convert your domain to punycode for this. There’s an online translator, of course: https://www.punycoder.com/

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.