Failed to Install SSL Certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I was doing the initial configuration, it asked me for the domain, the email and it generated an error when installing the SSL

It produced this output: Certbot was unable to authenticate some domains (authenticator: webroot). The certificate authority reported these issues:
Type: unauthorized
Detail: 2a02:4780:13:891:0:1395:adb3:2: Invalid response from 404

Tip: The certificate authority was unable to download the temporary challenge files created by Certbot. Make sure that the domains listed serve their content from the provided --webroot-path/-w and that the files created there are downloadable from the Internet.

Some challenges have failed.
Ask for help or search for solutions at Check the log file /var/log/letsencrypt/letsencrypt.log or rerun Certbot with -v for more details.
Oh! Something went wrong...

My web server is (include version): VPS

The operating system my web server runs on is (include version): Ubuntu 22.04 64bit con Node.js/OpenLiteSpeed

My hosting provider, if applicable, is: Hostinger

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hello @wins, welcome to the Let's Encrypt community. :slightly_smiling_face:

Using the online tool Let's Debug yields these results

Warning has multiple IP addresses in its DNS records. While they appear to be accessible on the network, we have detected that they produce differing results when sent an ACME HTTP validation request. This may indicate that some of the IP addresses may unintentionally point to different servers, which would cause validation to fail.
[Address=2a02:4780:13:891:0:1395:adb3:2,Address Type=IPv6,Server=LiteSpeed,HTTP Status=404] vs [Address=,Address Type=IPv4,Server=LiteSpeed,HTTP Status=200] 

All of the IP address should respond with the same results, but they are not.


And this is what I get with curl; note that the file sometestfile does not exist (well I highly doubt it exists) yet the server return success with HTTP/1.1 200 OK

$ curl -i
HTTP/1.1 200 OK
content-type: text/plain
content-length: 39
date: Wed, 21 Jun 2023 17:17:26 GMT
server: LiteSpeed
connection: Keep-Alive

Hello World! From OpenLiteSpeed NodeJS

Hello @Bruce5051, Thank you for your answer, can you tell me what I have to do to solve the error please


Sorry @wins I do not know LiteSpeed nor how to configure it.
Kindly wait to see if there are more knowledgeable Let's Encrypt community volunteers willing to assist. :slight_smile:


The first thing to do is fix your DNS settings. As Bruce's link to Let's Debug showed, your IPv4 address points to a different server than the IPv6 address.

You need to figure out which correct and then set the right values for your DNS A and AAAA records. Or, remove the AAAA if it can't work. Hostinger can help you with this.

(IPv4 returns this from a LiteSpeed server.  Probably a parking page)
curl -4
Hello World! From OpenLiteSpeed NodeJS

(IPv6 returns this also from LiteSpeed server)
curl -6
<!DOCTYPE html>
<html lang="en" class="no-js">
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
(... rest omitted but note botly in title ...)

Thank you very much @MikeMcQ , it's solved


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.