HTTPS URL still not working after i run certbot certonly --webroot


#1

Hi guys, anyone know why my webpage https is still not working even i have run “certbot certonly --webroot…” and returned “Congratulations! Your certificate and chain have been saved at…”

It still showing “Your connection is not secure…” when I visit using https://…

Please help anyone…appreciate…


#2

The certonly options means certbot will only save the issued certificate to your servers disk (by default at the location /etc/letsencrypt/live/yoursite.tld/fullchain.pem.

With certonly, you yourself are responsible to install the certificate into your webserver.

I would suggest using the Mozilla SSL Configuration Generator to use the appropriate configuration for your webserver.

You will need to change:

/path/to/private/key to /etc/letsencrypt/live/yoursite.tld/privkey.pem

And either:

/path/to/signed_certificate --> /etc/letsencrypt/live/yoursite.tld/cert.pem ánd
/path/to/intermediate_certificate --> /etc/letsencrypt/live/yoursite.tld/chain.pem

or

/path/to/signed_certificate_followed_by_intermediate_certs --> /etc/letsencrypt/live/yoursite.tld/fullchain.pem

You might want to choose to disable the HSTS Enabled option on the generator, until you’re sure your HTTPS works perfectly.


#3

Hmm…but the <VirtualHost *:443>… code where should I put? I cant locate the conf file…I quite confuse which conf actually my server is using…I found there is a default-ssl.conf also…


#4

Well, that totally depends on the webserver used and how you configured the webserver initially…


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.