HTTPS stopped working

Hi! Ive made my first own site a few months ago its running on apache2, got it running with https. i dont know when exactly, but a friend told me https doesnt work anymore, but i sadly didnt had the time to figure out what was wrong. so today i tried looking into it, ive been on it for about an hour now. and since i forgot everything i did back then, i just thought imma seek for help since google also wasnt able to help me. so i started off with using sudo certbot certificates Which spit spit out:

Found the following certs:
  Certificate Name:
    Serial Number: 4333940fba7738a69ce6607bb69f195d20a
    Key Type: RSA
    Expiry Date: 2023-05-21 18:19:17+00:00 (INVALID: EXPIRED)
    Certificate Path: /etc/letsencrypt/live/
    Private Key Path: /etc/letsencrypt/live/

So i googled a bit, and used sudo certbot --apache which then led to my first error which lets me back confused, i wish i could post the result, but my pc crashed so i dont have the output anymore. i now tried doing it again and got the following:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Please enter the domain name(s) you would like on your certificate (comma and/or
space separated) (Enter 'c' to cancel):
Renewing an existing certificate for
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.```

So why did i ran into an too many requests error? and how long will it take now untill i can try it again?

so here some more infos about the stuff.
server version is Apache/2.4.52 (Ubuntu)
my OS where the server runs on is Ubuntu 22.04.1 LTS
I have my own server, so i host it myself. so i have full root acess and everything to it.
I just use SFTP to upload the files to my server, and SSH to controll it through the terminal.
and the certbot version is certbot 1.21.0

before it started telling you this, it should've given you some kind of different error.

can you go through your logs and find out which?


I tried looking through it, the log is gigantic, and i dont really know where it starts/ends. so i just put the whole log untill the time where i think i started on pastebin. Letsencrypt log -

line 2299

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
  Type:   unauthorized
  Detail: Invalid response from 404

Something is messing with how certbot and apache interact. Can you show us your virtualhosts?


If you tell me how i can do that sure!

just out of curiosity, how did you get your first certificate, and did you modify your config since then?


I read through a lot of tutorials and followed them. somehow i got it working, then it broke. i had to reinstall the OS on my server, so i read a lot of tutorials again. one thing i definetly know is that i used the certbot --apache command. but thats all i remember. it could be good 5-8 months ago since i worked on it last time. And nope i didnt modify any configs, not that i know of at least. maybe i did and forgot it, im not sure tho.

I think you might want to start from

apachectl -t -D DUMP_VHOSTS

Might want to start by finding out why nginx is responding on that domain rather than Apache :slight_smile:

Request to:, Result: [Address=,Address Type=IPv4,
Server=nginx/1.18.0 (Ubuntu),HTTP Status=404],
Issue: Trace:
@0ms: Making a request to (using initial IP
@0ms: Dialing
@194ms: Server response: HTTP 404 Not Found


Thats all that appears.

VirtualHost configuration:
*:80          (/etc/apache2/sites-enabled/000-default.conf:1)

Thats a pretty good question, i had that too before i reinstalled my OS. i never used Nginx. and i never installed it, and i didnt even know its there :confused:
How do i solve that?

First: Ensure your DDNS points to your current IP


Second: Review the Apache config to ensure there are no "name:port" overlaps

sudo apachectl -t -D DUMP_VHOSTS


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.