HTTPS redirect not working after certbot install

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.videstra.net/traffic (root redirects to another web site)

I ran this command: Standard install of certbot following prompts and selecting option #2 for redirects

It produced this output: If I explicitly type https://www.videstra.net/traffic it works as expected, but if I type just www.videstra.net in my web browser it gets the unsecure http only.

My web server is (include version): Apache2/2.4.29

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

1 Like

I get a redirect to a secure videstra.com. Could your redirect be cached by any chance?

1 Like

Hi @videstra

there is a check of your domain, ~~3 hours old - https://check-your-website.server-daten.de/?q=videstra.net

Domainname Http-Status redirect Sec. G
http://videstra.net/ 174.138.40.195 301 https://videstra.net/ Html is minified: 100,00 % 0.204 A
http://www.videstra.net/ 174.138.40.195 301 https://www.videstra.net/ Html is minified: 100,00 % 0.203 A
https://videstra.net/ 174.138.40.195 GZip used - 198 / 268 - 26,12 % Inline-JavaScript (∑/total): 0/0 Inline-CSS (∑/total): 0/0 200 Html is minified: 119,64 % 3.750 B
small visible content (num chars: 30)
Redirecting to videstra.com
https://www.videstra.net/ 174.138.40.195 GZip used - 198 / 268 - 26,12 % Inline-JavaScript (∑/total): 0/0 Inline-CSS (∑/total): 0/0 200 Html is minified: 119,64 % 3.510 B
small visible content (num chars: 30)
Redirecting to videstra.com

There is no critical problem visible.

Both http versions are correct redirected to https.

Only problem: You don’t have a preferred version non-www or www. So some users have the www, other the non-www version.

1 Like

Thanks Osiris and JeurgenAuer - Yes, I likely have a cached copy. Good to hear there are no major problems. I did try the check-your-website link and found it hard to understand so though I would check here. Jerugen - how do I set a preferred version?

1 Like

Your question says: You didn’t read the result of your check.

There is a complete answer how to do that.

1 Like

Yup - sorry. Lot’s of stuff there and my brain got fried - just needed to slow down and read more carefully. Found the resources I needed. In the end the site is really for internal use anyway - so there’s no real need to set this. I did enable IPV6 based on the report and some advice floating around out there.
Thanks much for the help all!

1 Like

Sorry to go off on a tangent, and I don’t mean this as attack on you, but this version of Certbot is really old. And it’s not just you, there seem to be a lot of people still stuck on Certbot 0.31.0. I’m wondering if that’s an OS limitation?

I’m using Certbot 1.5.0. Are you able to update or upgrade your Certbot version? The cause of the issue you’re having might be fixed in later Certbot versions. (Or did clearing your cache fix things?)

At least Debian and the Certbot PPA are still on 0.31.

Isn’t that a major issue? I mean, that’s not just a few steps behind. Is there a reason Debian is disadvantaging it’s users like that?

I ditched Debian back in 2004 for multiple reasons, including a significant amount of its software being obsolete. Some things never change, I guess.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.