Live site not redirecting

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: jewelofthecommonwealth.xyz

I ran this command: certbot

It produced this output: Worked as expected (reinstall and renew both work)

My web server is (include version): apache 2.4.52

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: dedicated server

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.21.0

I recently set up a dev server fork of my main site. I ran certbot on the dev site - dev.jewelofthecommonwealth.xyz - and redirection to https works. But now redirection to https on the live site does not work. It was working before I set up the dev site. Not sure what to look for. The apache conf files look correct. They are showing the right lines for redirection. But it's not working on the live site. Certbot does not complain when I run it to reinstall or replace the cert for the live site.

It looks like something is missing from your config.

You can run certbot enhance --redirect and follow its instructions.

3 Likes

Can you please show the output of sudo apachectl -t -D DUMP_VHOSTS? And we'll go from there.

1 Like

Doing that asked me to select a domain. I did that. It then showed me a new "list" consisting only of the domain I selected, and asked me to make a choice. Since there was only one choice, I entered 1, and then certbot simply quit without error or warning.

This helped me solve it - thank you. The dump output showed me that a previous TLD for my site was still active with certbot. Running certbot delete and then reinstalling the cert for the current domain.tld fixed it. So - thanks!

2 Likes

I'm not sure why deleting the certificate was necessary?

1 Like

Because the domain for it doesn't exist any more. I had a different TLD when I first ran certbot on my site.

1 Like