HTTP-01 Status Invalid on new site / certificate with EE4

Hi all,

Sorry for being ‘that guy’, but I’ve been struggling with Let’s Encrypt for some time now. I just tried to create a new site within EasyEngine and am still getting failures.

I’d really appreciate it if somebody could point me in the right direction. I’m sure it’s something to do with how I’ve set up my domain, but I can’t work out what it is.

Thank you :slight_smile:

My domain is:

I ran this command: sudo ee site create --wp --letsencrypt

It produced this output:

Configuring project.
Creating WordPress site
Copying configuration files.
Starting site’s services.
Downloading and configuring WordPress.
Moved /var/www/htdocs/wp-config.php to /var/www/wp-config.php successfully
Checking and verifying site-up status. This may take some time.
Installing WordPress site.
Success: has been created successfully!
Starting SSL verification.
Warning: Challenge Authorization failed. Check logs and check if your domain is pointed correctly to this server.
Re-run ee site ssl after fixing the issue.
Warning: Challenge failed (response: {“type”:“http-01”,“status”:“invalid”,“error”:{“type”:“urn:ietf:params:acme:error:dns”,“detail”:“DNS problem: SERVFAIL looking up A for”,“status”:400},“url”:“",“token”:"GarcmZg99XXEGOdFt3wralu_xO1t4LM1Db-ZwAwhVKM”}).
Warning: Initiating clean-up.
[] Docker Containers removed.
[] site root removed.
Site deleted.

My web server is (include version): nginx version: openresty/

The operating system my web server runs on is (include version):

| OS | Linux 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:2 |
| | 8 UTC 2018 x86_64 |
| Shell | /bin/bash |
| PHP binary | /usr/bin/php7.2 |
| PHP version | |
| php.ini used | /etc/php/7.2/cli/php.ini |
| EE root dir | phar://ee.phar |
| EE vendor dir | phar://ee.phar/vendor |
| EE phar path | /home/steve |
| EE packages dir | |
| EE global config | /opt/easyengine/config/config.yml |
| EE project config | |
| EE version | 4.0.10 |

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): EE 4.0.10

FYI, my A records look like this. I’m using Linode’s own DNS.

A/AAAA Record

Hostname IP Address TTL Default
2a01:7e00::f03c:91ff:fea9:888e Default
mail Default
mail 2a01:7e00::f03c:91ff:fea9:888e Default
www Default
www 2a01:7e00::f03c:91ff:fea9:888e Default
1 Like

How many times did you try?

It may have just been a temporary network issue on the Let’s Encrypt side - I can’t currently reproduce the same error using your domain.


Thanks _az, really appreciate you trying. I tried 3 times in total and got the same response each time. I've turned off UFW as well, just in case, but I've got ports 80 and 443 open anyway.

1 Like

And I’ve just tried it again and it worked fine! Like _az said, it must have been a temporary issue with Let’s Encrypt.

Thanks for your help :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.