How to fix Let's Encrypt to make it works always

My domain is: https://www.dakotafanning.eu/

My hosting provider, if applicable, is: Fanbulous

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t think

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Direct Admin

I’ve been having a little problem. Untill yesterday Let’s Encrypt was working all fine, today as I’ve opened the site this is what happened: it looks like the gallery (powered by coppermine) is fine, next to the link there is the little lock, but if I head over to the other pages of the site (powered by wordpress) the little lock is missing, there is only the i inside the circle, while if I am inside the dashboard there is the little lock again. If I head over my hosting page it says SSL Status: Valid SSL Detected (SSL Expiry Date 05/05/2020).
I don’t know what to do to fix it, to have the whole site fine (I mean with the little lock again) also because to be honest I don’t understand where is the problem.
Thank you!

Hi @Stefy

checking your domain your certificate is ok - https://check-your-website.server-daten.de/?q=dakotafanning.eu

CN=dakotafanning.eu
	05.02.2020
	05.05.2020
expires in 86 days	
dakotafanning.eu, www.dakotafanning.eu - 2 entries

Both connections (non-www and www) use that certificate, that’s good.

But you have a lot of mixed content - 15 img elements - https://check-your-website.server-daten.de/?q=dakotafanning.eu#html-content-block-1-img

http://www.dakotafanning.eu/wp-content/uploads/2020/02/Elite.png

There should be an option in your WordPress to change the base url from http to https.

Thank you for your reply. I’ve forgot to mention that I did the “Force SSL with https redirect” option.
I’ve changed the general settings to https, but the little lock isn’t showing up again, what am I supposed to do? Re-upload all the media?

I wouldn’t say re-upload. But you may need to go into your pages & check all your images. If you’re using the classic editor, click on the text tab to see the html code & make sure all http is changed to https. If you use Gutenberg, then you’ll have to find the option where it shows you the html code so you can do the same thing. Either that or remove/re-add the images on the page (not re-upload everything)

Done it, now it looks like it works again!
Thank you so much

Woo hoo! Glad to help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.