How to fix 301 redirect with www

Nginx server install ssl letencrypt certbot my website open www and non www but i fix www
my .htaccess file use code 301 recricat with www but my website open www and non www how to fix this help

my file exampal

[[[[[[[[
server {
root /var/www/expal.life/public_html;
server_name expal.life www.expal.life;

       location / {
            try_files $uri $uri/ /index.php?$args;

}

     location ~ \.php$ {
           include snippets/fastcgi-php.conf;
            fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;


 }

        location ~ /\.ht {
deny all;

}

   listen [::]:443 ssl ipv6only=on; # managed by Certbot
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/expal.life/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/expal.life/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

      server {
if ($host = www.expal.life) {
    return 301 https://$host$request_uri;
} # managed by Certbot


if ($host = expal.life) {
    return 301 https://$host$request_uri;
} # managed by Certbot

listen 80;
listen [::]:80;

server_name expal.life www.expal.life;
return 404; # managed by Certbot

}

]]]]]]]]]]]

please help i have fix my url this tipe https://www.godsunsat.com

You do realize that domains need to be bought and renewed, do you?

% whois expal.life
Domain not found.
1 Like

this is exampal domain
my real domain is https://www.godsunsat.com

1 Like

Hi @mrkumar

checking your domain via https://check-your-website.server-daten.de/?q=godsunsat.com - you have correct redirects http -> https, Grade A.

But there is no preferred version -> Grade C.

Read the output, there is a rule you may use.

PS: Don’t mix redirects in your config with redirects in your .htaccess.

1 Like

sir i am indian my english is week sorry for any mistake

But there is no preferred version -> Grade C. what is this sir

I have 3 website hosts on my server, all three websites have the same problem.Tell me how to correct

this is my .htaccess file

BEGIN WordPress

The directives (lines) between BEGIN WordPress and END WordPress are

dynamically generated, and should only be modified via WordPress filters.

Any changes to the directives between these markers will be overwritten.

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

END WordPress

BEGIN WP Rocket v3.0.5.1

Use UTF-8 encoding for anything served text/plain or text/html

AddDefaultCharset UTF-8

Force UTF-8 for a number of file formats

AddCharset UTF-8 .atom .css .js .json .rss .vtt .xml

FileETag None is not enough for every server.

Header unset ETag

Since we’re sending far-future expires, we don’t need ETags for static content.

developer.yahoo.com/performance/rules.html#etags

FileETag None

Send CORS headers if browsers request them; enabled by default for images.

# mod_headers, y u no match by Content-Type?! SetEnvIf Origin ":" IS_CORS Header set Access-Control-Allow-Origin "*" env=IS_CORS

Allow access to web fonts from all domains.

<FilesMatch “.(eot|otf|tt[cf]|woff2?)$”>

Header set Access-Control-Allow-Origin “*”

Header set X-Powered-By "WP Rocket/3.0.5.1" Header unset Pragma Header append Cache-Control "public" Header unset Last-Modified

<FilesMatch “.(css|htc|js|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$”>

Header unset Pragma
Header append Cache-Control “public”


Expires headers (for better cache control)

ExpiresActive on

Perhaps better to whitelist expires rules? Perhaps.

ExpiresDefault “access plus 1 month”

cache.appcache needs re-requests in FF 3.6 (thanks Remy ~Introducing HTML5)

ExpiresByType text/cache-manifest “access plus 0 seconds”

Your document html

ExpiresByType text/html “access plus 0 seconds”

Data

ExpiresByType text/xml “access plus 0 seconds”
ExpiresByType application/xml “access plus 0 seconds”
ExpiresByType application/json “access plus 0 seconds”

Feed

ExpiresByType application/rss+xml “access plus 1 hour”
ExpiresByType application/atom+xml “access plus 1 hour”

Favicon (cannot be renamed)

ExpiresByType image/x-icon “access plus 1 year”

Media: images, video, audio

ExpiresByType image/gif “access plus 1 month”
ExpiresByType image/png “access plus 1 month”
ExpiresByType image/jpeg “access plus 1 year”
ExpiresByType video/ogg “access plus 1 month”
ExpiresByType audio/ogg “access plus 1 month”
ExpiresByType video/mp4 “access plus 1 month”
ExpiresByType video/webm “access plus 1 month”

HTC files (css3pie)

ExpiresByType text/x-component “access plus 1 month”

Webfonts

ExpiresByType application/x-font-ttf “access plus 1 month”
ExpiresByType font/opentype “access plus 1 month”
ExpiresByType application/x-font-woff “access plus 1 month”
ExpiresByType application/x-font-woff2 “access plus 1 month”
ExpiresByType image/svg+xml “access plus 1 month”
ExpiresByType application/vnd.ms-fontobject “access plus 1 month”

CSS and JavaScript

ExpiresByType text/css “access plus 1 year”
ExpiresByType application/javascript “access plus 1 year”

Gzip compression

# Active compression SetOutputFilter DEFLATE # Force deflate for mangled headers SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding # Don’t compress images and other uncompressible content SetEnvIfNoCase Request_URI \ \.(?:gif|jpe?g|png|rar|zip|exe|flv|mov|wma|mp3|avi|swf|mp?g|mp4|webm|webp|pdf)$ no-gzip dont-vary

Compress all output labeled with one of the following MIME-types

AddOutputFilterByType DEFLATE application/atom+xml \ application/javascript \ application/json \ application/rss+xml \ application/vnd.ms-fontobject \ application/x-font-ttf \ application/xhtml+xml \ application/xml \ font/opentype \ image/svg+xml \ image/x-icon \ text/css \ text/html \ text/plain \ text/x-component \ text/xml Header append Vary: Accept-Encoding AddType text/html .html_gzip AddEncoding gzip .html_gzip SetEnvIfNoCase Request_URI \.html_gzip$ no-gzip

END WP Rocket

I don’t use WordPress.

But that

says: You shouldn’t edit that file manual.

Instead, use the WordPress configuration.

.htaccess File with nagins server or not

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.