How to diagnostic "Too many flags setting configurators/installers/authenticators 'webroot' -> 'apache'"


#1

Hi, I’m upgrading from letsencrypt-auto to certbot-auto by following the instructions in https://certbot.eff.org/#ubuntutrusty-apache . However, I encountered an issue as described below:

My domain is:
new.forest.go.th

I ran this command:
# ./certbot-auto --apache

It produced this output:

Too many flags setting configurators/installers/authenticators ‘webroot’ -> ‘apache’

My operating system is:
Ubuntu 14.04.4 LTS, Trusty Tahr

My web server is:
Apache/2.4.7 (Ubuntu)

I can login to a root shell on my machine:
yes

letsencrypt.log:

2016-07-21 03:39:32,152:DEBUG:certbot.main:Root logging level set at 30
2016-07-21 03:39:32,152:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2016-07-21 03:39:32,152:DEBUG:certbot.main:certbot version: 0.8.1
2016-07-21 03:39:32,152:DEBUG:certbot.main:Arguments: [’–apache’, ‘-c’, ‘cli.ini’]
2016-07-21 03:39:32,152:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)

How can I get more info to fix the problem?

Thank you.


#2

There’s probably a conflicting setting in your cli.ini


#3

But I didn’t create any cli.ini for certbot-auto – just wgeted it from internet.

I even created another cli.ini (copied the content from https://github.com/certbot/certbot/blob/master/examples/cli.ini ) alongside certbot-auto and run:

# ./certbot-auto --apache -c cli.ini

But the result was still the same.


#4

the problem for me was the old letsencrypt install

doing a “sudo apt-get purge letsencrypt” ensuring the /etc/letsencrypt folder is emptied out fixed that particular error

I then had to work through about a million more errors with ssl configs.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.