How do i https the server's phpmyadmin?


#1

under plesk i can add LetsEncrypt to the domains, but when i go to phpmyadmin from my hosting features, then i receive an https error

how do i need to setup this ?


#2

Hi @Frank1000

you can’t get a public trusted certificate with an ip-number from Letsencrypt.

So use your domain name.


#3

Hi,

Extending @JuergenAuer’s answer.

You are using phpmyadmin directly on an IP address…
Normally, the best way to resolve this is change the IP address (in the address bar) to your let’s encrypt secured domain name.

For example, if you are visiting https://273.183.27.7:8443/phpmyadmin and it throws a security error, use https://my-domain-on-this-server.tld:8443/phpmyadmin instead.

Thank you


#4

You are using phpmyadmin directly on an IP address…
Normally, the best way to resolve this is change the IP address (in the address bar) to your let’s encrypt secured domain name. It’s really not possbile. Try changing it. Thanks and Regards, Alex Parkar


#5

ok thx for info



#6

I have different domain addresses sharing the IP address which all have LetsEncrypt activated in Plesk. While some domains by times did https just fine, and others remained “insecure”, rt now it seems all domains are showing “not safe”.
As far i understood the LetsEncrypt certificate renews itself periodically and i don’t need to take further action, but something along this path seems not yet to be understood well enough from me to get it to work properly and enduringly.


#7

Hi,

Do you own the server?
There might be some restart / re-configuration needed to tweak for the server owner.

Thank you


#8

no, not owning it.



#9

is this a correct setup ?


#10

It’s not a problem of this setup.

It’s a problem that you use the ip address in your browser, not your domain name.

And it’s impossible to say if you need the www - version or not.

Please share your domain name.


#11

onefh.com

i can reach the Plesk panel from any of the shared domain.com:8443

rt now every domain on the server is displayed as “not secure”



#12

https://onefh.com/ is correct, new Letsencrypt certificate, created Friday.

https://onefh.com:8443/ is wrong, there is a self signed certificate. There may be an internal configuration option.

www.onefh.com doesn’t have a nameserver entry, so you don’t need the www - option.


#13

any of the domains on my server will responded by an own developed single app, which furnishes the user with its own theme and UI per each domain. Can this be a problem for the correct functioning of LetsEncrypt ?


#14

ok thx for info. Yes the www option is not activated.

I had been advised to added the self signed certificate to encrypt the traffic to the Plesk panel itself, but nothing changed so far.
Question, should i remove the Self certificate again ?


#15

You can use Plesk via

https://onefh.com:8443/

instead of

https://yourip-number:8443/

So if this port uses the correct certificate (with onefh.com as domain name), you don’t need an exception to accept the self signed certificate.


#16

yes, i#ve been using it that way, but still, with or without the self signed or LetsEncrypt certificate, its “not secured”


#17

You have to install the onefh.com - certificate. There is the self signed -> this is insecure.


#18

how to install such certificate for onefh.com ?


#19

I don’t use Plesk. There must be an option to secure this admin panel.


#20

There is a help: