Home Assistant and CertBot

My domain is: casadelduckie.duckdns.org

I ran this command:See Image

It produced this output:See Image

It was suggested that I post this to the the community. Any ideas? Thank you.

Hi @steveothesane

if you are a new user, you can only post one image per post (I think, didn’t checked).

Add two answers.

2 Likes

So far I see ZERO images.

1 Like

Here’s the image (I hope). I see it.

Not sure it will change anything but try it with sudo before we look at other things:
sudo ./certbot-auto certonly --standalone

In this (official?) thread about Home Assistant

they seem to suggest installing Certbot using the OS package manager (with apt) rather than using certbot-auto. Did you try this method?

1 Like

So I officially registered my own domain, setup an email account, and now am hoping that my certificate will be valid as that seemed to be one of the reasons it wasn't working in the first place...I think. BUT....now I can't remember what I am to do now that I have a registered domain. Just venting/updating. I know the documentation is on here somewhere. I'll find it. Thank you. Oh, and about the "(official?) thread about Home Assistant", yeah tried that. Gave up. Probably too soon as I figured I'd just throw some money at the problem as see if it goes away. Nope. May need to revisit that. :roll_eyes:

1 Like

Welcome back, Steve :slightly_smiling_face:

This documentation?

1 Like

Probably. Thank you. Now, does anyone know how to get Certbot to run on Home Assistant? I'm still faced with the original error:
I run: sudo /usr/local/bin/certbot-auto --nginx
and get this:
"Sorry, I don't know how to bootstrap Certbot on your operating system!

You will need to install OS dependencies, configure virtualenv, and run pip install manually.
Please see https://certbot.eff.org/docs/contributing.html#prerequisites"

Officially recommended by Home Assistant:

Home Assistant Add-on: Letsencrypt

As seen here:

1 Like

My earlier reply suggested following the other documentation from the Home Assistant community and using apt-get to install Certbot, instead of certbot-auto. I don't know for sure whether this will work for you, but I'd still recommend trying it!

2 Likes

apt and apt-get are not recognized by bin. Now I haven't had the pleasure of using Linux in years so I"m very rusty. Comes with having to support Windows domains for the past several years I guess. So I can't remember a lot of the commands and since this OS seems to be a mish-mash of pieces put together a lot of what I remember doesn't seem to work. The part that sucks is my domain is fully functional and it works over port 80 but not port 443 so I had to block it in my firewall for now. However, I will try a few other techniques that the good old WWW can supply and I welcome all suggestions. Including the sarcastic and cynical ones. :grin:

Did you look at the official link from Home Assistant I suggested? It may save you worlds of headache.

I did and got stuck. I will give it a go again but as it is giving headaches to other "noobs" I figured I'd go direct to the source and see if anyone here had any other ideas that would save me some time with a simple, "Oh, yeah. Just do this and your are set." It isn't that I am impatient just that I don't have a lot of free time as, although most would understand who spend their entire life in front of the same machine doing bth their work and their hobbie, my loved ones don't see the separation as I go from my work to my hobbie without leaving the same laptop. LOL

@schoen

I am both amused and concerned by the huge disclaimers and list of assumptions at the top of the page you referenced from the Home Assistant Community.

I suppose we can't expect too much more from Home Assistant when the links to their Let's Encrypt add-on found on the HTTP page on their website just points to a GitHub project that is part of their add-on repository.

Not exactly the most user-friendly or confidence-inducing. It's as if they want to make things difficult and confusing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.