Help with ssl certificate error. please

Hi I wake up with This site can’t provide a secure connection sent an invalid response.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).

The index.html site is ok
Befor that I got awstats there

My domain is:

I ran this command:
apachectl -t -D DUMP_VHOSTS
It produced this output:
My web server is (include version):
port 80 namevhost (/etc/httpd/conf.d/m_vhost.conf:1)
port 443 namevhost (/etc/httpd/conf.d/m_vhost-le-ssl.conf:2)

Also run certbot -d and tried 1 - to reinstall the same certificate with no different results , 2 - to reinstall a new certificate with no different results
The certificate is valid
The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no
Virtualization: kvm
Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-1062.4.1.el7.x86_64
Architecture: x86-64

The version of my client is: certbot 0.39.0

1 Like


What is the result you’re wishing to achieve? Are you expecting to see your awstats page?

Can you post the full contents of these vhosts please?

  • /etc/httpd/conf.d/m_vhost.conf
  • /etc/httpd/conf.d/m_vhost-le-ssl.conf

I see that the certificate is valid and is explicitly for, not

$ echo | openssl s_client -connect -servername -verify_hostname 2>&1 | openssl x509 -noout -text | grep -E '(CN|DNS)'
        Issuer: C = US, O = Let's Encrypt, CN = Let's Encrypt Authority X3
        Subject: CN =

ok i delete the config file

What OS are you attempting to connect to the website from? I am showing successful connections from a Fedora 31 virtual machine.

This shows the redirect from HTTP to HTTPS working successfully

$ curl -IL
HTTP/1.1 301 Moved Permanently
Date: Thu, 19 Dec 2019 15:03:06 GMT
Server: Apache/2.4.41 (codeit) OpenSSL/1.1.1d
Content-Type: text/html; charset=iso-8859-1

HTTP/2 200 
date: Thu, 19 Dec 2019 15:03:06 GMT
server: Apache/2.4.41 (codeit) OpenSSL/1.1.1d
strict-transport-security: max-age=63072000; includeSubdomains;
x-frame-options: SAMEORIGIN
last-modified: Thu, 19 Dec 2019 10:55:40 GMT
etag: "22-59a0c66ea1f97"
accept-ranges: bytes
content-length: 34
x-frame-options: SAMEORIGIN
vary: User-Agent
cache-control: private, must-revalidate
content-type: text/html; charset=UTF-8

This shows retrieving the contents of the website successfully.

$ curl -L
welcome - please come back in 2 h 
1 Like

Im trying to connect from win 10 , google chrome last version

Can you clear your cache, use private mode, or even try a different browser to see if those connect successfully?

I E it says This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

Your TLS security settings aren’t set to the defaults, which could also be causing this error…

don t know what to think

cleared the cache , tried in IE, private mode , firefox … same thing . yestday was fine, no error

sooy for not showing the cookie section ,don’ t get the printscreen is says noo cookies and the red sign on it

Do you happen to run any third party antivirus on your computer such as Avast, ESET, Kaspersky, etc?

Can you show me the certificate details in Chrome and IE when you receive the error? It should look similar to this picture:

1 Like

got the extension , thats ok is shows as in your image , the only thing i got I can t access the website and I don t know why ?? is like crazy . are you able to see the site at your end , just checking

Yes I am. I can see it in a browser and via curl requests.

1 Like

okay thats great, good to know

At this point I think we’ve narrowed down the problem to be your host machine. I don’t have any recommendations for getting that fixed though. Best of luck with it.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.