Help with IPV6 only server

I’m getting this message:
no working IP addresses found for ""
This is the command I’m running:
sudo certbot certonly --standalone -d

I’m not seeing other people having the same problem, am I doing something obviously wrong?


I’m following instructions I found online, I don’t recall making a config file.
Should it be here? /etc/letsencrypt/cli.ini

I’m not running a webserver, I thought the --standalone told certbot to spin up it’s own webserver or something like that?

It does, but it so happens that Certbot only added IPv6 support in --standalone a week ago, thanks to efforts by @erica.

Since you're not running certbot-auto, you probably don't have a recent enough version of Certbot to have IPv6 support with --standalone, due to this bug. If you install another copy of Certbot with the certbot-auto method, you should.

@rg305's suggestion is right for selecting a port number (443 vs. 80), but I suspect there's also a deeper problem at work here. :slight_smile:

1 Like

Nice of @erica to release that feature just in time for me. :grinning:

Latest version on Ubuntu is apt-get is 14.2,
I tried the certbot-auto and it worked fine.

Awesome, thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.