Certbot doesn't create an IPv6 socket


#1

When I run certbot on my Raspian 9 system I get the error:

Stopping server at 0.0.0.0:80…

This wouldn’t be a problem if this was a IPv4 host, but this host only has an IPv6 address. Is there a way to force certbot is creating a IPv6 socket?

Version installed in Raspbian: certbot 0.10.2

The command I execute is: certbot -vvv certonly -d $domain

I just tested with the latest greatest certbot and there it works fine. I guess it’s just a bug, which will never be fixed in Debian 9.


#2

Hi,

The information you provided above is insufficient in order for us to answer your question.

Could you also please at least provide us the following information?

Your web server:
The command you executed:
The full output:

Thank you


#3

I updated my initial post.


#4

Hi,

For the authenticator options, which one did you choose? (Standalone? Webroot? Apache? Nginx?)

Also, you did not answer the “Web server version” question.

Thank you


#5

The web server version shouldn’t matter here. It appears that standalone is in use, as that’s the only authenticator that would start listening on a port.

What certbot version are you having issues with, and which version is working? My guess is that the repo just doesn’t have the actual latest version, which is a common issue with OS repos. In this event, it’s usually better to install Certbot-auto from the EFF website instead.


#6

Yeah, the standalone plugin has supported IPv6 since Certbot 0.15.0.

This is an awkward situation. :grimacing: Upgrading Certbot is the “right” thing to do, but using certbot-auto on an RPi is probably painful.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.