Help installing SSL cert on a owncloud server on a AWS instance

I’ve got an owncloud server setup on AWS through Sain3. I can connect to it through http, but not https. I emailed their support on how to convert it to https, and they sent me a link to your website. I connected to the instance through putty and ran the commands per certbot, selecting apache and Ubuntu 14.04 LTS. The problem is I’m not sure what to put as the domain name. I connect to the owncloud server using the IP address of 52.42.140.69.

When it comes to setting up SSL certs, I have no experience.

Please fill out the fields below so we can help you better.

My domain is:don’t know

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):Ubuntu 14.04 LTS

My hosting provider, if applicable, is:AWS

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

You have to get a domain name to get a certificate, not just IP address. Many TLDs (e.g. .com, .org, .xyz) can be had for less than $10/year. Once you have purchased a domain name, you will use the DNS settings of your domain registrar to point it, or any subdomains, to that IP address. Then you can get certificates.

There are also services that give you a single subdomain of theirs for free, but it’s been so long I don’t know of any currently operating off the top of my head.

Some CAs offer certificates for IP addresses. Let’s Encrypt is not one of them.

Yes, but this is a forum for Let’s Encrypt support. :stuck_out_tongue_winking_eye:

Thanks everyone. I will get a domain name or a subdomain in my case for the owncloud server then try the Let’s Encrypt instructions after that to get the SSL cert installed on it.

I have the domain name setup with the IP address and now I can go to the owncloud server through my browser by going to owncloud.chameleonis.com, but when I run the command ‘sudo certbot --apache’ when connected to the server via putty, I get the following error:

No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):owncloud.chameleonis.com
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for owncloud.chameleonis.com
Enabled Apache socache_shmcb module
Enabled Apache ssl module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. owncloud.chameleonis.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Timeout

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: owncloud.chameleonis.com
    Type: connection
    Detail: Timeout

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

I think you have a firewall (at either host or network level) blocking inbound connections to port 443. When I try to connect to port 443, it times out as if such connections were being ignored. If there were no firewall in place, the connection should either be accepted or rejected immediately.

Thanks, I had to add an inbound rule for port 443 for the AWS instance and it’s all working now. Thanks for everyone’s help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.