Help for issue certification with nginx server


#1

Hello all!
I’m using Docker env with exposed 80, 443 port.
And I tested standalone and nginx plugin command for certbot.
But all of them doesn’t work for me.
So I tried with --manual option for debug.
As i understand certbot wants me to make url like “http://demo.lomin.ai/.well-known/acme-challenge/HHv-e7A6inc_lGwWqyfrzBfEZRm2LlLHWsIbpEDaEEw” to response ‘HHv-e7A6inc_lGwWqyfrzBfEZRm2LlLHWsIbpEDaEEw.9QWlxiDYoLlCDmfW3iNIOr5c9QYGGyBwfEZdCELrlKo’.
So I make the url with the key even I can access by myself.
But the http-01 challenge is not possible to me…
Anybody have idea to solve it?

My domain is:

demo.lomin.ai

I ran this command:

certbot-auto certonly --manual

It produced this output:

Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. demo.lomin.ai (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://demo.lomin.ai/.well-known/acme-challenge/EWbLNaAWwRZGM1UCqSvbIIxFFaoH09wPUEwVuYucCb0: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:Domain: demo.lomin.ai
    Type: connection
    Detail: Fetching
    http://demo.lomin.ai/.well-known/acme-challenge/EWbLNaAWwRZGM1UCqSvbIIxFFaoH09wPUEwVuYucCb0:
    Timeout during connect (likely firewall problem)To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.
  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version):

nginx version: nginx/1.13.12

The operating system my web server runs on is (include version):

PRETTY_NAME=“Debian GNU/Linux 9 (stretch)”
NAME=“Debian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
ID=debian

My hosting provider, if applicable, is:

AWS route 53.

I can login to a root shell on my machine (yes or no, or I don’t know):

yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no


#2

I also tested it on https://letsdebug.net/demo.lomin.ai/11953
But i can’t find the reason of error.


#3

#4

I see you posted another thread while waiting for the spam filter, so I’ve closed this one to keep all the replies in one place.