Certbot: Type:connection; Detail: fetching

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for example.eu
Waiting for verification...
Challenge failed for domain example.eu
http-01 challenge for example.eu
Cleaning up challenges
Some challenges have failed.

 - The following errors were reported by the server:

   Domain: example.eu
   Type:   connection
   Detail: Fetching
   Timeout during connect (likely firewall problem)

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My web server is (include version): VPS

The operating system my web server runs on is (include version): Ubuntu 20.04 LTS

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

MY NGINX CONFIGURATION (/etc/nginx/sites-available/example.eu)

server {
    server_name example.eu;

    listen 80;

    location / {
         proxy_set_header Host $host;
           proxy_set_header X-Real-IP $remote_addr;
           proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
           proxy_set_header X-Forwarded-Proto $scheme;

           client_max_body_size 0;
           add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
           add_header Referrer-Policy "same-origin";


P.S. I linked "example.eu" to /etc/nginx/sites-enabled/

What is more, firewall was disabled, so nothing had to block any traffic.

Welcome to the Let's Encrypt community! :slightly_smiling_face:
I am not able to access or ping cloud hamster.eu. Are you sure your firewall isn't blocking port 80/443? If not, it might be time to check your nginx configuration.

Connection to your domain shows APACHE:

curl -Iki [redacted]
HTTP/1.1 200 OK
Date: Fri, 05 Feb 2021 17:25:08 GMT
Server: Apache
Cache-control: max-age=300
Connection: close
Content-Type: text/html; charset=UTF-8

Have you confirmed that DNS is properly resolving the FQDN to the right IP?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.