Help for certbot itself cannot be provided until it is installed


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

http:wolfiep.com

I ran this command:

wget https://dl.eff.org/certbot-auto && chmod a+x certbot-auto

then…

./certbot-auto certonly --webroot -w /var/www/html/ -d wolfiep.com -d www.wolfiep.com

It produced this output:

Requesting to rerun ./certbot-auto with root privileges…
Usage: certbot-auto [OPTIONS]
A self-updating wrapper script for the Certbot ACME client. When run, updates
to both this script and certbot will be downloaded and installed. After
ensuring you have the latest versions installed, certbot will be invoked with
all arguments you have provided.

Help for certbot itself cannot be provided until it is installed.

–debug attempt experimental installation
-h, --help print this help
-n, --non-interactive, --noninteractive run without asking for user input
–no-bootstrap do not install OS dependencies
–no-self-upgrade do not download updates
–os-packages-only install OS dependencies and exit
–install-only install certbot, upgrade if needed, and exit
-v, --verbose provide more output
-q, --quiet provide only update/error output;
implies --non-interactive

All arguments are accepted and forwarded to the Certbot client when run.

My web server is (include version):

My webserver is a linux google cloud wordpress click to deploy

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes


#2

That’s weird.

Try

sudo ./certbot-auto

and then your original command again.


#3

Thanks _az this went through although it carried on prompting me further I ended up with this and am unsure whether this is normal

We were unable to find a vhost with a ServerName or Address of www.wolfiep.com.
Which virtual host would you like to choose?
(note: conf files with multiple vhosts are not yet supported)

1: wordpress.conf | | | Enabled
2: wordpress-le-ssl.conf | wolfiep.com | HTTPS | Enabled

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel):

many thanks!


#4

You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/wolfiep.com.conf)

What would you like to do?

1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1
Keeping the existing certificate
Created an SSL vhost at /etc/apache2/sites-available/wordpress-le-ssl.conf
Enabled Apache socache_shmcb module
Enabled Apache ssl module
Deploying Certificate to VirtualHost /etc/apache2/sites-available/wordpress-le-ssl.conf
Enabling available site: /etc/apache2/sites-available/wordpress-le-ssl.conf

We were unable to find a vhost with a ServerName or Address of www.wolfiep.com.
Which virtual host would you like to choose?
(note: conf files with multiple vhosts are not yet supported)

1: wordpress.conf | | | Enabled
2: wordpress-le-ssl.conf | wolfiep.com | HTTPS | Enabled

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel):


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.