Hello Please am trying get ssh certificate for my website but this is the Error message I keep seeing please assist me

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:www.mygraceexpress.com

I ran this command:sudo certbot --apache

It produced this output:Action ‘graceful’ failed.
The Apache error log may have more information.
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/certbot/error_handler.py”, line 108, in _call_registered
self.funcs-1
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 323, in _cleanup_challenges
self.auth.cleanup(achalls)
File “/usr/lib/python3/dist-packages/certbot_apache/configurator.py”, line 2312, in cleanup
self.restart()
File “/usr/lib/python3/dist-packages/certbot_apache/configurator.py”, line 2175, in restart
self._reload()
File “/usr/lib/python3/dist-packages/certbot_apache/configurator.py”, line 2203, in _reload
raise errors.MisconfigurationError(error)
certbot.errors.MisconfigurationError: Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Hi,

What webserver are you currently running? use netstat -tupln to check (see which process is listening to port 80/443)

If you are using apache / httpd, where did you install it from? (Is it possible that the process is being called by an alternative apache/version?)

1 Like

Please this is the result i get after running the command
emmanuelfiadufe145@wordpress-2-vm:~$ netstat -tupln
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN -
tcp6 0 0 :::33060 :::* LISTEN -
tcp6 0 0 :::80 :::* LISTEN -
tcp6 0 0 :::22 :::* LISTEN -
tcp6 0 0 :::443 :::* LISTEN -
udp 0 0 0.0.0.0:68 0.0.0.0:* -
udp 0 0 127.0.0.1:323 0.0.0.0:* -
udp6 0 0 ::1:323 :::* -

1 Like

Please am running apache httpd:// webserver.

Please this is the result i get after running the command
emmanuelfiadufe145@wordpress-2-vm:~$ netstat -tupln
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN -
tcp6 0 0 :::33060 :::* LISTEN -
tcp6 0 0 :::80 :::* LISTEN -
tcp6 0 0 :::22 :::* LISTEN -
tcp6 0 0 :::443 :::* LISTEN -
udp 0 0 0.0.0.0:68 0.0.0.0:* -
udp 0 0 127.0.0.1:323 0.0.0.0:* -
udp6 0 0 ::1:323 :::* -

1 Like

I install it from the same google cloud

What’s your certbot version? sudo certbot --version
Have you tried to use certbot with --webroot? (This will place file directly into your website path instead of modifying your apache configuration)

I think certbot might tried to brought up another apache instance which (obvisouly) can’t while your main instance is running, maybe try to switch to webroot will help.

The webroot command will look like this sudo certbot --webroot --webroot-path Your_File_Path -d your_domains -i apache This will attempt to obtain a certificate with webroot and install it to apache.

1 Like

This is the result I get when I run sudo --webroot-path

certbot version: 0.31.0

emmanuelfiadufe145@wordpress-2-vm:/opt/bitnami/letsencrypt$ sudo ./certbot-auto certonly --webroot -w /opt/bitnami
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Please enter in your domain name(s) (comma and/or space separated) (Enter ‘c’
to cancel): /apps/wordpress/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com
Obtaining a new certificate
An unexpected error occurred:
The server will not issue certificates for the identifier :: Error creating new order :: Cannot issue for “-d”: Domain name needs at le
ast one dot (and 1 more problems. Refer to sub-problems for more information.)
Please see the logfiles in /var/log/letsencrypt for more details.

Please I didn’t understand this statement,

Domain name needs at least one dot (and 1 more problems. Refer to sub-problems for more information.)
Please see the logfiles in /var/log/letsencrypt for more details

sudo ./certbot-auto --webroot --webroot-path /apps/wordpress/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com -i apache

Please this is the result I get after runing the above command.

emmanuelfiadufe145@wordpress-2-vm:/opt/bitnami/letsencrypt$ sudo ./certbot-auto --webroot --webroot-path /apps/wordpress/htdocs/ -d www
.mygraceexpress.com -d mygraceexpress.com -i apache
/apps/wordpress/htdocs/ does not exist or is not a directory

You need to adjust the commands and all parts need to be in one line.
sudo ./certbot-auto --webroot --webroot-path /opt/bitnami/apps/wordpress/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com -i apache

1 Like

Please am so grateful for your help so far

Upon serveral adjustment this what i get again, Please any help

emmanuelfiadufe145@wordpress-2-vm:/opt/bitnami/letsencrypt$ sudo ./certbot-auto --webroot --webroot-path/apps/wordpress-2-vm/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com -i apache
usage:
certbot-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --webroot-path/apps/wordpress-2-vm/htdocs/

There’s a space between the --webroot-path and the actual folder.
sudo ./certbot-auto --webroot --webroot-path /opt/bitnami/apps/wordpress/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com -i apache

1 Like

Hello thanks once again, per the above suggestion the error still persist after many attempt, could you please assist me how to get the right path.
Best regards.

Please kindly assist me,
This is the error am getting after runing this command.
sudo ./certbot-auto --webroot --webroot-path /opt/bitnami/apps/wordpress/htdocs/ -d www.mygraceexpress.com -d mygraceexpress.com -i apache

self.funcs-1
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/_internal/client.py”, line 630, in _rollback_and_restart
self.installer.restart()
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/_internal/configurator.py”, line 2410, in restart
self._reload()
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/_internal/configurator.py”, line 2437, in _reload
raise errors.MisconfigurationError(error)
MisconfigurationError: Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
IMPORTANT NOTES:

  • An error occurred and we failed to restore your config and restart
    your server. Please post to
    https://community.letsencrypt.org/c/help with details about your
    configuration and this error you received.
  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/www.mygraceexpress.com/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/www.mygraceexpress.com/privkey.pem
    Your cert will expire on 2020-11-05. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot-auto
    again with the “certonly” option. To non-interactively renew all
    of your certificates, run “certbot-auto renew”
1 Like

Please I tried to restart my apache server and this is the error i got, please how do I remove or correct this error. thanks.

emmanuelfiadufe145@wordpress-2-vm:~$ sudo /opt/bitnami/ctlscript.sh restart
AH00526: Syntax error on line 13 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
Invalid command ‘RewriteRule^/(.)https://www.mygraceexpress.com/$1[R,L]’, perhaps misspelled or defined by a module not included in th
e server configuration
apache config test fails, aborting
/opt/bitnami/php/scripts/ctl.sh : php-fpm stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql started at port 3306
/opt/bitnami/php/scripts/ctl.sh : php-fpm started
AH00526: Syntax error on line 13 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
Invalid command 'RewriteRule^/(.
)https://www.mygraceexpress.com/$1[R,L]’, perhaps misspelled or defined by a module not included in th
e server configuration
apache config test fails, aborting

1 Like

Hi,

I really don’t know how exactly to fix this issue, because it’s Bitnami related and Bitnami uses another set of Apache configuration (which i finally know why your certbot isn’t working).

For Bitnami related websites, you should use https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/ for instruction on obtaining a Let’s Encrypt certificate.

1 Like

Hi @Emmanuelfiadufe

if you use Bitnami, you have to use the Bitnami script to install the certificate.

So -i apache may be wrong. Your first command - certonly.

Then check the Bitnami documentation how to install the created certificate.

2 Likes

Ok, thanks for your help

1 Like