Getting certificate for host ionos / domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: affiliate marketing

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

@datanetworkbiz, and welcome to the LE community forum :slight_smile:

You haven't provided enough information, nor even a question, to proceed with.

Let's begin at the beginning...
What problem are you having?


I have a domain called The hosting company is ionos.
I cannot get "Let's Encrypt" to work on my domain.In fact I can't even get the domain to propagate properly. Ionos domains are difficult to work with so it's no wonder that I am having trouble with Lets Encrypt. I have been dealing with this for quite some time so I am frustrated by it all.

You may need to talk with Ionos. Some system running nginx is intercepting the ACME HTTP Challenge. Normal requests to your domain go to an Apache server. Apache is mis-configured and causes a redirect loop.

You have both IPv4 and IPv6 addresses and both behave the same so that's good.

I don't see that we are the best place for your problem right now. But, if we become the best place we need more info. Making us guess and tease out answers from you is not good use of everyone's time. Letting us know exactly what you tried to get "Lets Encrypt to work", the errors you saw, what server you use, and the rest from the questionnaire is just a starting point.

These all use IPv6 as that is what Let's Encrypt prefers if you have both. IPv4 responds the same though.

# See Apache 
curl -I6
HTTP/1.1 302 Found
Server: Apache

# This domain also Apache but redirects to itself (loops)
curl -I6
HTTP/1.1 302 Found
Server: Apache

# Sample HTTP Challenge.  See nginx responding
curl -I6
HTTP/1.1 204
Server: nginx
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Cache-Control: no-cache, no-store, max-age=0, must-revalidate

Thanks for the insight. I'll keep on trying.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.