Getting a certificate


#1

Hello,
I am having trouble to get a certificate for my domain.
Could you help me please.
Thanks a lot.
Patrick

My domain is:
w4mp1r3.com

I ran this command:
I am using a custom client for the challenge https://github.com/xenolf/lego/issues

It produced this output:
[www.w4mp1r3.com] acme: Error 400 - urn:acme:error:connection - Fetching http://www.w4mp1r3.com/.well-known/acme-challenge/jx0uDKy5ni-nHz6cche8eXV6Xh_r5ys6Y94DDDq6VB0: Timeout during connect (likely firewall problem)
Error Detail:
Validation for www.w4mp1r3.com:80
Resolved to:
18.216.136.121
Used: 18.216.136.121

My web server is (include version):
Non applicable

The operating system my web server runs on is (include version):
Ubuntu SMP Fri May 25 21:47:34 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

My hosting provider, if applicable, is:
C2 instance on AWS Amazon

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes I can.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

Hi @w4mp1r3

http://www.w4mp1r3.com/ doesn’t work. Is there a webserver? If you want to use http-01 - challenge, there is a file

http://www.w4mp1r3.com/.well-known/acme-challenge/file-with-a-random-filename

required. But there is no webserver, instead a timeout.


#3

Hi @JuergenAuer,

I finally solved this issue and just like the error message was saying,
it was due to a firwall problem.
Thanks for your help anyway.

Cheers,
Patrick


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.