Generated certificate with wrong server IP

Hello,

I installed on my home server OwnCloud on Ubuntu Server 16.04. Then I pointed the subdomain server.xxxx.com to the IP of the server. After that I created a let’t encrypt certificate. The problem is that when I created an “A” DNS record in the domain control panel I wrote a wrong IP address(.117 instead of .107). I fixed the “A” record but when I tried to regenerate the certificate I got this error:

miroslavpetrov@ubuntu:~$ sudo certbot --apache -d server.xxxxxxx.com
[sudo] password for miroslavpetrov:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for server.xxxxxxxxxxxx.com
Enabled Apache socache_shmcb module
Enabled Apache ssl module
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. server.xxxxxxxxx.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Timeout

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: server.xxxxxxxxx.com
   Type:   connection
   Detail: Timeout

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.
miroslavpetrov@ubuntu:~$

Thank you in advance!

Hi @miroslav.petrov,

Can you share the domain name(s) you are trying to issue for when you see this error? It will make debugging significantly easier!

The domain name is server.miroslavpetrov.com

Thanks for sharing that!

I can see there are two authoritative DNS servers for miroslavpetrov.com. When I queried them both directly I got the .107 IP for server. that you say is the correct one. I think that means the problem isn’t DNS or that if it was, it has since been fixed (sometimes there can be delays between when you change the record in the control panel and when your authoritative DNS servers pick up the changes).

When I try to connect to 79.134.160.107:443 I see the same timeout error that you are reporting Certbot presented as an error.

Do you have any kind of firewall or something that could be blocking requests on port 443? Are you able to connect to 79.134.160.107:443 from an outside network?

Hello! Thank you for helping me. I have no firewall installed. However, I might not configured the apache properly.
I haven’t changed anything in the default.conf of apache. I only followed the steps in this guide:
https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-16-04

I fixed it. It turned out the problem was a wrong .conf file in /etc/apache2/sites-enabled.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.