Generate a certificate on Windows without installing it

Hi @cpu,

Thank you for answering. I have considered your suggestion, however I decided to apply a single certificate for the moment. I was hoping if you could help me, either you or someone else on how to generate a sertificate under Windows. I have tried with ACME powershell cmdlet, but I got to the point that I have to complete the challenges. It seems that I have to generate them trough the shell itself, but when I try I receive this error:
" Handler: manual
Complete-ACMEChallenge : Unable to find an Identifier for the given reference"

Which I am not 100% sure what it means since everything seem fine.

My second question is - Is there a way I could generate a certificate on windows and use it without assigning it to a particular web server?

Hi @Sunfl0wa,

Since this is a separate question than your initial Jetty ACME client question I split it off into its own Help topic with a more accurate title so that you can get better help.

Hmmm. I’m afraid I don’t know anything about the ACME powershell cmdlet client. You should consider opening an issue with the maintainers if you haven’t since this seems like it may be a bug with that client.

Unfortunately I don’t know the answer to this either (I’m not a Windows person :blush:) but hopefully someone in the forum will know more.

Have you looked at some of the other ACME clients that support Windows? Perhaps one of them will advertise a feature that lets you get a certificate without installing it in IIS/another webserver automatically.

Good luck!

@cpu thank you for moving the question for me I appreciate it! I was just not sure if I should open another topic. :slight_smile:
I am not windows guy myself also, that is why I am asking so many questions, but you know the task is a task and it has to be finished. :slight_smile:
However, I am not 100% sure how to generate such a certificate on Linux as well, so if you have the knowledge for that I’d appreciate if you point me where to look at.

I will give a look on the other ACME clients. Hopefully someone has had this issue before or thought of an answer so could participate and make my life easier. :slight_smile:

1 Like

Happy to help!

We’ve all been there :slight_smile:

Depending on your needs a short-term solution might be using ZeroSSL’s online tool for generating a certificate: https://zerossl.com/free-ssl/#howtocrt I mostly recommend this as a short term option because it is a manual process you’ll have to redo every 90 days.

For Linux I recommend that you try Certbot: https://certbot.eff.org/ You can plug in your Linux distribution and webserver into the Certbot website and it will help you get started. There are also lots of Certbot users (& some developers!) in the community forum if you get stuck.

1 Like

@cpu :slight_smile: WIll certbot work with Jetty? Because I’ve tried to look around and to see how the things are happening and I saw that a webserver needs to be added and Jetty wasn’t listed there.
It’s just literally the first time I am dealing with certificates in that matter so I am still exploring how the world works.

Certbot won’t support Jetty out-of-box. I believe you could use Certbot to issue a certificate in “certonly” mode and then configure Jetty to use it but it might not be straight-forward.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.