Fixing Certificate Issue on Google Compute Engine

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.kingkblite.com

I ran this command: the normal install procedures for letsencrypt on a bitnami wordpress install

It produced this output: as you navigate some pages, they are not secured. why is this? this is also present on my other sites that I secure

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Hi @georgejr6

checking your domain there is no error visible - https://check-your-website.server-daten.de/?q=kingkblite.com

Your certificate is ok:

CN=kingkblite.com
	27.02.2020
	27.05.2020
expires in 78 days	kingkblite.com, www.kingkblite.com - 2 entries

both connections use that certificate. There is no mixed content reported. Not via the own parsing, not via the Screenshot creation:

Chrome-Connection: secure. secure connection settings. The connection to this site is encrypted and authenticated using TLS 1.3, X25519, and AES_256_GCM.

Chrome-Resources : secure. all served securely. All resources on this page are served securely.

If it is not the main page: Samples are required.

1 Like

Here is an example of what I am facing another site that was present on the site that I listed

Hi @georgejr6,

Some parts of the site you mentioned do have this same error, which is called a mixed content error. This is not a problem with the certificate or HTTPS setup, but with the content of the site—it’s loading subresources within the page insecurely over HTTP instead of HTTPS. An example would be if your HTML page includes something like <img src="http://example.com/image.jpg" /> instead of <img src="https://example.com/image.jpg" />, or the same for videos, scripts, frames, iframes, etc.

You can probably identify the specific problems with a tool like https://whynopadlock.com/ or with your web browser’s developer tools.

But that’s another domain, not your site. Checking that domain - there is mixed content - https://check-your-website.server-daten.de/?q=fetch.properties

A style attribute

http://elementor-modern-min.realhomes.io/wp-content/uploads/2019/01/cta-bg.jpg

that creates the mixed content warning.

This is MY SITE its just another issue i am facing. How can I fix this?

you can’t, because that resource isn’t available over https in a trusted way:

https://elementor-modern-min.realhomes.io/wp-content/uploads/2019/01/cta-bg.jpg

get realhomes.io to use https properly on their subdomains or host that photo somewhere else.

Change that link to https.

PS: There is no https, so add a valid certificate. Or copy the image, so you can use https.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.