First time user and failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:unifi.marksemails.com

I ran this command: certbot --nginx, I’ve also run it manually, with -webroot, certonly the list goes on.

It produced this output:

Failed authorization procedure. unifi.marksemails.com (http-01): urn:ietf:params:acme:error:connection :: The server co uld not connect to the client to verify the domain :: Fetching http://unifi.marksemails.com/.well-known/acme-challenge/ sb58OH_2TvgiRg6FbYkYLQaA_-Tr7NlhCEZ6IcJQLn8: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: unifi.marksemails.com
    Type: connection
    Detail: Fetching
    http://unifi.marksemails.com/.well-known/acme-challenge/sb58OH_2TvgiRg6FbYkYLQaA_-Tr7NlhCEZ6IcJQLn8:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Not sure. I installed nginx as a reverse proxy. I assume apache, but haven’t dug into it too much

The operating system my web server runs on is (include version): CentOS 7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Hi @jamesmct

your port 80 doesn’t answer ( https://check-your-website.server-daten.de/?q=unifi.marksemails.com ):

Domainname Http-Status redirect Sec. G
http://unifi.marksemails.com/
70.181.14.108 -14 10.030 T
Timeout - The operation has timed out
https://unifi.marksemails.com/
70.181.14.108 -2 1.367 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 70.181.14.108:443
http://unifi.marksemails.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
70.181.14.108 -14 10.027 T
Timeout - The operation has timed out
Visible Content:

An open port 80 / http is required if you want to use http-01 validation.

Stupid ISP. Blocking by default all services. It worked internally, which oddly made it look like it worked externally.

Looking at upgrading services to business class and opening the ports. I will follow up then.

Thanks for the reality check

1 Like