Failed to connect to let’s encrypt. Synology NAS

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: Get a Certificate from Let's Encrypt

It produced this output: Failed to connect to let’s encrypt. Please make sure the domain name is valid

My web server is (include version): synology

The operating system my web server runs on is (include version): synology

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Welcome to the Let's Encrypt Community :slightly_smiling_face:

Please read here first:


Thank you. I only need 1 certificate.

The problem was solved thru the article by opening port 80.

Stay safe


You're quite welcome! :blush:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.