Failed authorization procedure on OVH Host


#1

Hi there,

I’m trying to get Letsencrypt to work on my Ubuntu 16.04 NGINX/Cloudflare server. This is being hosted by OVH. For some reason, when I try to run the letsencrypt certonly, I get the big message asking if I want to overwrite the previous domains, when I press expand, I get this error

Failed authorization procedure. www.trueknifettt.com (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.trueknifettt.com/.well-known/acme-challenge/7CRKWs1H6TuBJGM8LBDrxwDuEiWE_DNvwIpvC8BxSJo: "

404 Not Found

Not Found

<p"

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: www.trueknifettt.com
Type: unauthorized
Detail: Invalid response from http://www.trueknifettt.com/.well-
known/acme-challenge/7CRKWs1H6TuBJGM8LBDrxwDuEiWE_DNvwIpvC8BxSJo:
"

404 Not Found

Not Found

<p"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

Any help is much appreciated :slight_smile:
Thanks!


#2

I’ll just give this a bump


#3

bumperao :stuck_out_tongue: still need help


#4

I have no experience with cloudflare or OVH, so my help might not be all that helpful!

Your question didn’t say what command you used with certonly, or what else you tried with --expand. Can you give a little more information there?

“The client lacks authorisation” implies you didn’t run the client as root. In general, certbot requires that you run it as root. Also, I assume you’re using certbot as the client? You didn’t provide that information, either!

Since you said “when I try to run the letsencrypt certonly”, does that mean you’re using the official client but haven’t updated in a while? (It’s name changed from letsencrypt to certbot a while ago.) There have been changes to the way Let’s Encrypt’s servers authorise against clients, so you might need to update your client.

It’s good you’ve provided the output you received, but I don’t know what you did to get it! You need to provide more information about what you actually did to get the results you posted.

Also, I just tried going to www.trueknifettt.com (which appears to be the site you’re trying to get a certificate for), and I was almost immediately redirected to www.nfoservers.com. That could also be a big problem for you :wink: Did you set up the redirect or is the domain wrong?

Can you confirm what domain you’re trying to get a certificate for? Was it www.trueknifettt.com? Is there supposed to be three "t"s at the end?

I didn’t answer you earlier because I have no experience with cloudflare or hosted servers (I run my own server at home). I’m guessing nobody else answered because you didn’t provide enough information for people to diagnose the problem!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.