Unable to create an cert


#1

My domain is:
panel.techturtlehosting.nl

I ran this command:
letsencrypt certonly -d panel.techturtlehosting.nl

It produced this output:
Failed authorization procedure. panel.techturtlehosting.nl (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://panel.techturtlehosting.nl/.well-known/acme-challenge/stjN1CiRbrdW90YCWOHeWwMzI-tL-27-gH9VP6mqTOU: "

404 Not Found

Not Found

<p"

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: panel.techturtlehosting.nl
    Type: unauthorized
    Detail: Invalid response from http://panel.techturtlehosting.nl
    /.well-known/acme-challenge/stjN1CiRbrdW90YCWOHeWwMzI-
    tL-27-gH9VP6mqTOU: "

    404 Not Found

    Not Found

    <p"

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address.

My web server is (include version):
Nginx 1.10.3 ubuntu

The operating system my web server runs on is (include version):
Ubuntu 16.04

My hosting provider, if applicable, is:
Contabo

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

Hi @WoofFighter

you have two ip-addresses - ipv4 and ipv6. But the content is different:

https://letsdebug.net/panel.techturtlehosting.nl/2463

IPv4IPv6Discrepancy
Warning
panel.techturtlehosting.nl has both AAAA (IPv6) and A (IPv4) records. While they both appear to be accessible on the network, we have detected that they produce differing results when sent an ACME HTTP validation request. This may indicate that the IPv4 and IPv6 addresses may unintentionally point to different servers, which would cause validation to fail.
[Address Type=IPv4,Server=nginx/1.10.3 (Ubuntu),HTTP Status=404] vs [Address Type=IPv6,Server=Apache/2,HTTP Status=404]

You can remove the ipv6-address, create the certificate, later fix the ipv6 - problem.


#3

Hey,
When I try it again I get the error that nginx is running on it but I turned it off


#4

Did you hit the “rerun test”?

Now it’s green:

All OK!

No issues were found with panel.techturtlehosting.nl. If you are having problems with creating an SSL certificate, please visit the Let’s Encrypt Community forums and post a question there.

PS: So creating a new certificate should work.


#5

I didnt hit it but I get the error that the port is taken and by nginx but I turned it off (Using service nginx stop and systemctl stop nginx)


#6

and I exandently press reset instead of restart


#7

But it works now!! THanks @JuergenAuer


#8

Yep, it works now. Perhaps add a redirect http -> https, http://panel.techturtlehosting.nl/ shows the simple “Welcome to nginx!” - page.


#9

Now it shows more :joy: but how to close this?


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.