Failed authorization procedure - AWS, apache, godaddy


#1

Hi Everyone,

I am new to this, so please forgive me for anything stupid :slight_smile:

So I bought a Godaddy Domain: www.fergusoncandles.co.uk

Running apache2

It is hosted on AWS, don’t worry I have all the correct ports open haha.

I am getting this error:
Failed authorization procedure.
Detail: Failed to connect to 184.168.221.5:443 for TLS-SNI-01

The server it is trying to connect to, I assume is my DNS server, it is not owned by me. My AWS server has a different IP address.

I think there is just something basic that I am missing, if there is anything more you need to know, just let me know :slight_smile:

All help is appreciated :smiley:


#2

Hi @jeff694,

The A record in DNS for that name actually does point to 184.168.221.5.

$ host www.fergusoncandles.co.uk www.fergusoncandles.co.uk is an alias for fergusoncandles.co.uk. fergusoncandles.co.uk has address 184.168.221.5 fergusoncandles.co.uk mail is handled by 10 mailstore1.secureserver.net. fergusoncandles.co.uk mail is handled by 0 smtp.secureserver.net.

And similarly

$ dig a www.fergusoncandles.co.uk

; <<>> DiG 9.10.3-P4-Ubuntu <<>> a www.fergusoncandles.co.uk
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37857
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 5

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.fergusoncandles.co.uk. IN A

;; ANSWER SECTION:
www.fergusoncandles.co.uk. 3555 IN CNAME fergusoncandles.co.uk.
fergusoncandles.co.uk. 555 IN A 184.168.221.5 […]

If you want to validate to some other server, you’ll need to point your domain to that other server in DNS first.


#3

Thanks for getting back to me :slight_smile:

I don’t own 184.168.221.5, is that a problem?

The amazon server I own starts with 52.xxx.xxx.xxx


#4

@jeff694, this is a basic issue about your webhosting setup… how are you planning to point your domain name at your web server? That’s part of what makes your web server be a web server for that domain!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.