Failed authorization procedure : help please [SOLVED]


#1

Hi All,

Setting up certs is all new to me and i’ve been struggling to set up a public facing nextcloud box over the past few days and have finaly admitted defeat and am asking for help.

I keep getting a ‘Failed authorisation procedure’ message when trying to generate a cert for the subdomain alexandria.afe-uk.com

It’s probably a dns issue but I can’t see it no matter how many times I re-try or re-jigger anything/everything…

A fresh pair of eyes will probably spot it stright off.

Anyhoo thanks for any help.

Cheers


#2

Can you provide us with a bit more background please.

What is the operating system ?

do you have root access ?

Do you have any control panel ?

Do you have any firewall / router blocking access to your server ? ( I can’t reach alexandria.afe-uk.com from the internet in a quick test )


#3

Sorry, my bad, got a bit carried away setting the firewall and turned everything off :frowning:(

Anyhoo back online now.

The setup is as follows : Ubuntu server 16.04LTS with Apache2 running : IP 217.46.209.165 or alexandria.afe-uk.com

When i try to run certbot-auto --apache --agree-tos --email xx@afe-uk.com --redirect -d alexandria.afe-uk.com
I get 'failed authorisation procedure alexandria.afe-uk.com (tls-sni-01) etc error

Any ideas where i’m going wrong ?

Thanks


#4

What’s the full output of certbot?

Also, I’m investigating why some people have trouble with the tls-sni-01 challenge, especially if they get an error in which the ACME server complains about the certificate having the wrong domain names. Therefore, could you run and also post the output of the following command?

grep -i virtualhost /etc/apache2/sites-enabled/*

#5

Sorry for not replying earlier.

Thanks for the help - turned out to be a firewall issue with the ISP router blocking ports - once opened everything worked as it should.

cheers


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.