Even though I have renewed SSL certificate website is showing expired

My domain is: https://fitnationplus.com/

I ran this command: certbot renew

I also tried deleting the certificate and again issuing the certificate.

My web server is (include version): Openlitespeed

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine: Yes

I'm using a control panel to manage my site: No

The version of my client is Certbot 0.40.0

@Sushantfitness Welcome to the community.

You probably just need to reload or restart your litespeed server. I am not familiar with it so am not sure of the commands but hopefully you know :slight_smile:


Tried but not solved the problem.

@Sushantfitness Are you sure? I am seeing a new certificate now with openssl:

subject= /CN=fitnationplus.com
issuer= /C=US/O=Let's Encrypt/CN=R3
notBefore=Oct 23 08:06:03 2021 GMT
notAfter=Jan 21 08:06:02 2022 GMT

Certificate chain
 0 s:/CN=fitnationplus.com
   i:/C=US/O=Let's Encrypt/CN=R3
 1 s:/C=US/O=Let's Encrypt/CN=R3
   i:/C=US/O=Internet Security Research Group/CN=ISRG Root X1
 2 s:/C=US/O=Internet Security Research Group/CN=ISRG Root X1
   i:/O=Digital Signature Trust Co./CN=DST Root CA X3

What are you using that still shows the old one?

Update: Can also check here:


Yes, it is solved now. I was just typing my URL in the browser on my PC. Now I tied it in different device and it is showing SSL. Thanks


I want to automate the renewal of SSL, can you point me towards a proper guide to do that. Thank You


@Sushantfitness I will make an assumption that you used the certonly command to initially create the cert. Let me know if that is not the case.

One way is to use the --deploy-hook option on the renew command. The hook command runs after a renewal that successfully creates a new cert. You set the command to restart litespeed or whatever else you need. And, if you have not already, setup a cron to run the renew. So, something like:

certbot renew --deploy-hook "command to reload/restart litespeed"

This is described here:

You could also add the deploy hook in a certonly command and it will save the value in the renewal conf. That avoids needing to use it with the renew command.


Yes, When issuing the certificate I used certonly command. Thanks for the info.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.