Error with Python Virtual Enviroment

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
http://71.47.196.227/
I ran this command:
sudo /usr/local/bin/certbot-auto --nginx
It produced this output:
Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
augeas-lenses is already the newest version (1.11.0-3).
ca-certificates is already the newest version (20190110).
gcc is already the newest version (4:8.3.0-1+rpi2).
libaugeas0 is already the newest version (1.11.0-3).
libffi-dev is already the newest version (3.2.1-9).
python is already the newest version (2.7.16-1).
python-dev is already the newest version (2.7.16-1).
python-virtualenv is already the newest version (15.1.0+ds-2).
virtualenv is already the newest version (15.1.0+ds-2).
libssl-dev is already the newest version (1.1.1d-0+deb10u2+rpt1).
openssl is already the newest version (1.1.1d-0+deb10u2+rpt1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages.

pip prints the following errors:

Collecting ConfigArgParse==1.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 12))
Downloading https://files.pythonhosted.org/packages/66/37/dd9fcb3b19c1dceea450ee994952e311a96dd827bb09ee19169c3427e0d3/ConfigArgParse-1.0.tar.gz (40kB)
Collecting certifi==2019.11.28 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 14))
Downloading https://files.pythonhosted.org/packages/b9/63/df50cac98ea0d5b006c55a399c3bf1db9da7b5a24de7890bc9cfd5dd9e99/certifi-2019.11.28-py2.py3-none-any.whl (156kB)
Collecting cffi==1.13.2 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 17))
Downloading https://files.pythonhosted.org/packages/2d/bf/960e5a422db3ac1a5e612cb35ca436c3fc985ed4b7ed13a1b4879006f450/cffi-1.13.2.tar.gz (460kB)
Collecting chardet==3.0.4 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 51))
Downloading https://files.pythonhosted.org/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl (133kB)
Collecting configobj==5.0.6 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 54))
Downloading https://files.pythonhosted.org/packages/64/61/079eb60459c44929e684fa7d9e2fdca403f67d64dd9dbac27296be2e0fab/configobj-5.0.6.tar.gz
Collecting cryptography==2.8 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 56))
Downloading https://files.pythonhosted.org/packages/be/60/da377e1bed002716fb2d5d1d1cab720f298cb33ecff7bf7adea72788e4e4/cryptography-2.8.tar.gz (504kB)
Collecting distro==1.4.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 78))
Downloading https://files.pythonhosted.org/packages/ea/35/82f79b92fa4d937146c660a6482cee4f3dfa1f97ff3d2a6f3ecba33e712e/distro-1.4.0-py2.py3-none-any.whl
Collecting enum34==1.1.6 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 81))
Downloading https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting funcsigs==1.0.2 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 86))
Downloading https://files.pythonhosted.org/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting idna==2.8 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 89))
Downloading https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl (58kB)
Collecting ipaddress==1.0.23 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 92))
Downloading https://files.pythonhosted.org/packages/c2/f8/49697181b1651d8347d24c095ce46c7346c37335ddc7d255833e7cde674d/ipaddress-1.0.23-py2.py3-none-any.whl
Collecting josepy==1.2.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 95))
Downloading https://files.pythonhosted.org/packages/de/bb/4949857070b6601eacc209478823745cd79d72cf1c0bb8407aebb772677b/josepy-1.2.0-py2.py3-none-any.whl (57kB)
Collecting mock==1.3.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 98))
Downloading https://files.pythonhosted.org/packages/b2/50/664a70b87408bb6c14c1af2337efa64eb8d1af80c933531758b8fb41ec25/mock-1.3.0-py2.py3-none-any.whl (56kB)
Collecting parsedatetime==2.5 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 101))
Downloading https://files.pythonhosted.org/packages/4e/26/7612745a21452f6d822c0868ff7168dd8cf592645b2a553a177e1de43901/parsedatetime-2.5-py2-none-any.whl (40kB)
Collecting pbr==5.4.4 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 104))
Downloading https://files.pythonhosted.org/packages/7a/db/a968fd7beb9fe06901c1841cb25c9ccb666ca1b9a19b114d1bbedf1126fc/pbr-5.4.4-py2.py3-none-any.whl (110kB)
Collecting pyOpenSSL==19.1.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 107))
Downloading https://files.pythonhosted.org/packages/9e/de/f8342b68fa9e981d348039954657bdf681b2ab93de27443be51865ffa310/pyOpenSSL-19.1.0-py2.py3-none-any.whl (53kB)
Collecting pyRFC3339==1.1 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 110))
Downloading https://files.pythonhosted.org/packages/c1/7a/725f5c16756ec6211b1e7eeac09f469084595513917ea069bc023c40a5e2/pyRFC3339-1.1-py2.py3-none-any.whl
Collecting pycparser==2.19 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 113))
Downloading https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl (111kB)
Collecting pyparsing==2.4.6 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 115))
Downloading https://files.pythonhosted.org/packages/5d/bc/1e58593167fade7b544bfe9502a26dc860940a79ab306e651e7f13be68c2/pyparsing-2.4.6-py2.py3-none-any.whl (67kB)
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 118))
Downloading https://files.pythonhosted.org/packages/41/e6/4b6740cb3e31b82252099994cea751c648b846aa7874343c31d68c2215be/python-augeas-0.5.0.tar.gz (90kB)
Collecting pytz==2019.3 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 120))
Downloading https://files.pythonhosted.org/packages/e7/f9/f0b53f88060247251bf481fa6ea62cd0d25bf1b11a87888e53ce5b7c8ad2/pytz-2019.3-py2.py3-none-any.whl (509kB)
Collecting requests==2.22.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 123))
Downloading https://files.pythonhosted.org/packages/51/bd/23c926cd341ea6b7dd0b2a00aba99ae0f828be89d72b2190f27c11d4b7fb/requests-2.22.0-py2.py3-none-any.whl (57kB)
Collecting requests-toolbelt==0.9.1 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 126))
Downloading https://files.pythonhosted.org/packages/60/ef/7681134338fc097acef8d9b2f8abe0458e4d87559c689a8c306d0957ece5/requests_toolbelt-0.9.1-py2.py3-none-any.whl (54kB)
Collecting six==1.14.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 129))
Downloading https://files.pythonhosted.org/packages/65/eb/1f97cb97bfc2390a276969c6fae16075da282f5058082d4cb10c6c5c1dba/six-1.14.0-py2.py3-none-any.whl
Collecting urllib3==1.25.8 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 132))
Downloading https://files.pythonhosted.org/packages/e8/74/6e4f91745020f967d09332bb2b8b9b10090957334692eb88ea4afe91b77f/urllib3-1.25.8-py2.py3-none-any.whl (125kB)
Collecting zope.component==4.6 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 135))
Downloading https://www.piwheels.org/simple/zope-component/zope.component-4.6-py2.py3-none-any.whl (70kB)
Collecting zope.deferredimport==4.3.1 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 137))
Downloading https://files.pythonhosted.org/packages/63/e3/05b02057b56cd9c59d848b67aff1cc701e1d2237055ebd0d0c1f44331186/zope.deferredimport-4.3.1-py2.py3-none-any.whl
Collecting zope.deprecation==4.4.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 140))
Downloading https://files.pythonhosted.org/packages/f9/26/b935bbf9d27e898b87d80e7873a0200cebf239253d0afe7a59f82fe90fff/zope.deprecation-4.4.0-py2.py3-none-any.whl
Collecting zope.event==4.4 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 143))
Downloading https://files.pythonhosted.org/packages/c5/96/361edb421a077a4c208b4a5c212737d78ae03ce67fbbcd01621c49f332d1/zope.event-4.4-py2.py3-none-any.whl
Collecting zope.hookable==5.0.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 146))
Downloading https://files.pythonhosted.org/packages/35/7e/d7ffdd410a9b4aa97d175af1718baa6b741ec6a60baa668354dd3da4e26c/zope.hookable-5.0.0.tar.gz
Collecting zope.interface==4.7.1 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 186))
Downloading https://files.pythonhosted.org/packages/c3/05/bf3130eb799548882ce61b7c3d2dbc5d4d5cc6e821efa8786c5273d56844/zope.interface-4.7.1.tar.gz (151kB)
Collecting zope.proxy==4.3.3 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 226))
Downloading https://files.pythonhosted.org/packages/e2/44/bea546c55488c044351e51ebf23bf440b19876e0069a418cadc1bd5736f7/zope.proxy-4.3.3.tar.gz (44kB)
Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 274))
Downloading https://files.pythonhosted.org/packages/fd/21/0c6f33829fadec8aca0c1ebb4d6f8101c05899356a58d1b2e506cb77cf18/letsencrypt-0.7.0-py2-none-any.whl
Collecting certbot==1.3.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 278))
Downloading https://files.pythonhosted.org/packages/4b/3d/afa627553cdd9b69553637fd15d07bee32f31e9401e5413fd7806367e54a/certbot-1.3.0-py2.py3-none-any.whl (231kB)
Collecting acme==1.3.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 281))
Downloading https://files.pythonhosted.org/packages/3d/11/19d48550ad114026657c657a3da6c9b278e7d3d8a53aa2180d5c5216c67a/acme-1.3.0-py2.py3-none-any.whl
Collecting certbot-apache==1.3.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 284))
Downloading https://files.pythonhosted.org/packages/80/83/d5ba575061fd936050ee9f87fe008a6802877c6263f3b7958d7b0e5c8bfe/certbot_apache-1.3.0-py2.py3-none-any.whl (86kB)
Collecting certbot-nginx==1.3.0 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 287))
Downloading https://files.pythonhosted.org/packages/aa/62/673bdbf118bd01bddcad887b1ea2134b07f6382477084e32029d57326ba8/certbot_nginx-1.3.0-py2.py3-none-any.whl (45kB)
Requirement already satisfied: setuptools>=1.0 in /opt/eff.org/certbot/venv/lib/python2.7/site-packages (from josepy==1.2.0->-r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 95))
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pycparser==2.19 from https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl#sha256=bc15573b7c6edd24407526dbbc7a0bd33d80d8af44231c37f58d73f56ff9cab6 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 113)):
Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
Got bc15573b7c6edd24407526dbbc7a0bd33d80d8af44231c37f58d73f56ff9cab6

zope.component==4.6 from https://www.piwheels.org/simple/zope-component/zope.component-4.6-py2.py3-none-any.whl#sha256=74f55521dec189c08d98341edce929eba6bb2404662d1878f1b289af46f6f6a5 (from -r /tmp/tmp.L4howrOwSU/letsencrypt-auto-requirements.txt (line 135)):
    Expected sha256 ec2afc5bbe611dcace98bb39822c122d44743d635dafc7315b9aef25097db9e6
         Got        74f55521dec189c08d98341edce929eba6bb2404662d1878f1b289af46f6f6a5

=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

My web server is (include version):

The operating system my web server runs on is (include version):
Nginx (Latest)
My hosting provider, if applicable, is:
N/A
I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Latest Version (Ran the command and it tried to make the certificate…)

1 Like

this is not a domain, it’s an ip (v4) address.

It looks like a corrupted download. Did you only try once? – I’m wrong, it’s probably certbot’s requirements.txt that doesn’t have the hashes from piwheels.org. There’s not an easy solution, you should open an issue on certbot’s github to add them.

1 Like

HOWEVER, you can install certbot from raspbian’s repositories:

apt-get install certbot python3-certbot-nginx
2 Likes

Perhaps we should Raspbian to the certbot instructions. Shouldn’t be too hard, as Raspbian is as far as I know almost the same as Debian :stuck_out_tongue:

3 Likes

I gave the IP because I don’t have a domain yet… so that’s the way to the website until then.

Hi @BentonGrayson

you can’t create a certificate with an ip address.

A worldwide unique domain name is required.

2 Likes

I just bought a domain and configured it with google. Ran the program and it appears to be working now. It says that the certificate is good and will expire on 2020-6-20. Now I just need to wait for google to update the domain name to make my website appear. I’ll let you know if any further issues appear. Thank you for your help!

1 Like

If http validation worked, your domain is working already.

2 Likes

My domain is: “www.graysquid.net”. The website won’t load though, probably because google hasn’t updated their cloud yet. They said it can take up to 48 hours.

1 Like

This worked. I made sure to check on the install pages as well to see if I missed this, turns out I didn’t. I just used the Debian (Other). Maybe it’s worth making one specifically for Raspberry Pi… :man_shrugging:

Anyway, thanks for helping me figure this out. I’ll see if the certificate truly worked when google updates their servers in the next 48 hours and makes my domain live. Thanks!

1 Like

Yep. I agree with this.

1 Like

is 71.47.196.227 the right ip address?

then it’s not google, it’s your server timing out.

it could be some firewall somewhere (not likely, validation worked) or you just have no webserver on.

Yes the IP address is correct. Google did say that it can take up to 48 hours to work though… so I’m not sure. I’ll look into it more. Thanks for letting me know