Error running certbot-auto

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:sudo /etc/letsencrypt/certbot-auto certonly --agree-tos webroot -w /data/ -d -d -d -d

It produced this output:Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)
Get:1 stretch InRelease [15.0 kB]
Get:2 stretch InRelease [25.4 kB]
Get:3 stretch/main armhf Packages [11.7 MB]
Get:4 stretch/contrib armhf Packages [56.9 kB]
Fetched 11.8 MB in 9s (1,287 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
ca-certificates is already the newest version (20161130+nmu1+deb9u1).
gcc is already the newest version (4:6.3.0-4).
gcc set to manually installed.
openssl is already the newest version (1.1.0k-1~deb9u1).
openssl set to manually installed.
python is already the newest version (2.7.13-2).
python-dev is already the newest version (2.7.13-2).
python-dev set to manually installed.
The following packages were automatically installed and are no longer required:
coinor-libipopt1v5 libmumps-seq-4.10.0 libraw15
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
Suggested packages:
augeas-doc augeas-tools
Recommended packages:
The following NEW packages will be installed:
augeas-lenses libaugeas0 libffi-dev libssl-dev python-virtualenv python3-virtualenv virtualenv
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 2,362 kB of archives.
After this operation, 8,194 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 stretch/main armhf augeas-lenses all 1.8.0-1+deb9u1 [420 kB]
Get:2 stretch/main armhf libaugeas0 armhf 1.8.0-1+deb9u1 [260 kB]
Get:3 stretch/main armhf libffi-dev armhf 3.2.1-6 [159 kB]
Get:4 stretch/main armhf libssl-dev armhf 1.1.0k-1~deb9u1 [1,385 kB]
Get:5 stretch/main armhf python-virtualenv all 15.1.0+ds-1 [61.1 kB]
Get:6 stretch/main armhf python3-virtualenv all 15.1.0+ds-1 [57.7 kB]
Get:7 stretch/main armhf virtualenv all 15.1.0+ds-1 [19.7 kB]
Fetched 2,362 kB in 2s (899 kB/s)
Selecting previously unselected package augeas-lenses.
(Reading database … 138818 files and directories currently installed.)
Preparing to unpack …/0-augeas-lenses_1.8.0-1+deb9u1_all.deb …
Unpacking augeas-lenses (1.8.0-1+deb9u1) …
Selecting previously unselected package libaugeas0.
Preparing to unpack …/1-libaugeas0_1.8.0-1+deb9u1_armhf.deb …
Unpacking libaugeas0 (1.8.0-1+deb9u1) …
Selecting previously unselected package libffi-dev:armhf.
Preparing to unpack …/2-libffi-dev_3.2.1-6_armhf.deb …
Unpacking libffi-dev:armhf (3.2.1-6) …
Selecting previously unselected package libssl-dev:armhf.
Preparing to unpack …/3-libssl-dev_1.1.0k-1~deb9u1_armhf.deb …
Unpacking libssl-dev:armhf (1.1.0k-1~deb9u1) …
Selecting previously unselected package python-virtualenv.
Preparing to unpack …/4-python-virtualenv_15.1.0+ds-1_all.deb …
Unpacking python-virtualenv (15.1.0+ds-1) …
Selecting previously unselected package python3-virtualenv.
Preparing to unpack …/5-python3-virtualenv_15.1.0+ds-1_all.deb …
Unpacking python3-virtualenv (15.1.0+ds-1) …
Selecting previously unselected package virtualenv.
Preparing to unpack …/6-virtualenv_15.1.0+ds-1_all.deb …
Unpacking virtualenv (15.1.0+ds-1) …
Processing triggers for install-info (6.3.0.dfsg.1-1+b1) …
Setting up libssl-dev:armhf (1.1.0k-1~deb9u1) …
Setting up libffi-dev:armhf (3.2.1-6) …
Processing triggers for libc-bin (2.24-11+deb9u4) …
Setting up python3-virtualenv (15.1.0+ds-1) …
Setting up augeas-lenses (1.8.0-1+deb9u1) …
Setting up python-virtualenv (15.1.0+ds-1) …
Processing triggers for man-db ( …
Setting up virtualenv (15.1.0+ds-1) …
Setting up libaugeas0 (1.8.0-1+deb9u1) …
Processing triggers for libc-bin (2.24-11+deb9u4) …
Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages.

pip prints the following errors:

Collecting ConfigArgParse==0.14.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 12))

***************** Had to obfuscate a lot of URL’s so I could post this
Collecting asn1crypto==0.24.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 14))
Downloading xxxx:// (101kB)
Collecting certifi==2019.6.16 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 17))
Downloading xxxxx:// (157kB)
Collecting cffi==1.12.3 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 20))
Downloading xxxxx:// (456kB)
Collecting chardet==3.0.4 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 49))
Downloading xxxxx:// (133kB)
Collecting configobj==5.0.6 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 52))
Downloading xxxx://
Collecting cryptography==2.7 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 54))
Downloading xxxxx:// (495kB)
Collecting distro==1.4.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 71))
Downloading xxxxx://
Collecting enum34==1.1.6 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 74))
Downloading xxxxx://
Collecting funcsigs==1.0.2 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 79))
Downloading xxxxx://
Collecting future==0.17.1 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 82))
Downloading xxxxx:// (829kB)
Collecting idna==2.8 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 84))
Downloading xxxxx:// (58kB)
Collecting ipaddress==1.0.22 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 87))
Downloading xxxxx://
Collecting josepy==1.2.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 90))
Downloading xxxx:// (57kB)
Collecting mock==1.3.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 93))
Downloading xxxxx:// (56kB)
Collecting parsedatetime==2.4 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 96))
Downloading xxxxx:// (40kB)
Collecting pbr==5.4.2 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 99))
Downloading xxxxx:// (110kB)
Collecting pyOpenSSL==19.0.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 102))
Downloading xxxxx:// (53kB)
Collecting pyRFC3339==1.1 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 105))
Downloading xxxxx://
Collecting pycparser==2.19 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 108))
Downloading (111kB)
Collecting pyparsing==2.4.2 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 110))
Downloading xxxx:// (65kB)
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 113))
Downloading xxxxx:// (90kB)
Collecting pytz==2019.2 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 115))
Downloading xxxxx:// (508kB)
Collecting requests==2.21.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 118))
Downloading xxxxx:// (57kB)
Collecting requests-toolbelt==0.9.1 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 121))
Downloading xxxxx:// (54kB)
Collecting six==1.12.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 124))
Downloading xxxxx://
Collecting urllib3==1.24.3 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 127))
Downloading xxxx:// (118kB)
Collecting zope.component==4.5 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 130))
Downloading xxxxx:// (70kB)
Collecting zope.deferredimport==4.3.1 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 133))
Downloading xxxx://
Collecting zope.deprecation==4.4.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 136))
Downloading xxxxx://
Collecting zope.event==4.4 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 139))
Downloading xxxxx://
Collecting zope.hookable==4.2.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 142))
Downloading xxxxx://
Collecting zope.interface==4.6.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 153))
Downloading xxxx:// (150kB)
Collecting zope.proxy==4.3.2 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 183))
Downloading xxxxx:// (43kB)
Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 203))
Downloading xxxxx://
Collecting certbot==0.38.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 207))
Downloading xxxx:// (341kB)
Collecting acme==0.38.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 210))
Downloading xxxx:// (86kB)
Collecting certbot-apache==0.38.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 213))
Downloading xxxx:// (253kB)
Collecting certbot-nginx==0.38.0 (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 216))
Downloading xxxx:// (88kB)
Requirement already satisfied: setuptools>=1.0 in /opt/ (from josepy==1.2.0->-r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 90))
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pycparser==2.19 from (from -r /tmp/tmp.bJtPFAaACJ/letsencrypt-auto-requirements.txt (line 108)):
Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
Got bc15573b7c6edd24407526dbbc7a0bd33d80d8af44231c37f58d73f56ff9cab6

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip

for possible solutions.
You may also find some support resources at .

My web server is (include version): nginx 1.10.3

The operating system my web server runs on is (include version): Raspberry Pi debian stretch

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): it didn’t get installed because of the error

Are you using Debian or Raspbian?

See this thread:

It happens because pip is configured to get packages from instead of PyPI, and they don't match.

The workaround suggested in that thread was to install Certbot with apt instead of using certbot-auto. Would that work for you? Do you need a newer version?

Edit: The other suggested workaround was to disable piwheels in your pip.conf.

Thank you. I disabled piwheels and it worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.