Error trying to renew

I’m new and I don’t know how this works, I can add more info, but as I don’t know what I should not post, I only post the error, Thanks.

My domain is:

I ran this command: sudo letsencrypt renew

It produced this output:

noel@ubuntu:~$ sudo letsencrypt renew
[sudo] password for noel:
Processing /etc/letsencrypt/renewal/
2019-11-28 21:36:55,288:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/ produced an unexpected error: Deserialization error: Wrong directory fields. Skipping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)
1 renew failure(s), 0 parse failure(s)

My web server is (include version): apache2 2.4.18-2ubuntu3.13

The operating system my web server runs on is (include version): Ubuntu 16.04.3 LTS

My hosting provider, if applicable, is: Arsys

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no, i’m using ssh

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): letsencrypt 0.4.1

1 Like

I’m not sure why that error is happening, but version 0.4.1 is really old. (In fact, the project renamed from letsencrypt to Certbot soon after 0.4.1 was released!) It even uses Let’s Encrypt’s old ACMEv1 API, which is being phased out.

Do you have the xenial-updates repository enabled? If not, edit /etc/apt/sources.list to enable it.

After that, try running sudo apt update and sudo apt full-upgrade, and you should get a newer version of Certbot, which might work better.

You can also get an even newer version by enabling the Certbot PPA and then upgrading. If you want to do that, you can use something like:

sudo apt install software-properties-common
sudo add-apt-repository universe
sudo add-apt-repository ppa:certbot/certbot
sudo apt update
sudo apt full-upgrade

Edit: I’m guessing this issue, apparently fixed in version 0.6.0, is the problem:


Thanks, I updated and everything worked. A lot of thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.