Failing to renew certificate


#1

Hi, I am not an expert or intend to be I run a small Ubuntu 16.04 VPS with a Let’s Encrypt SSL
using find i went to the directory and tried running

./letsencrypt-auto certonly --renew --email myemail@gmail.com -a manual -d mydomain.com --dry-run --agree-tos

So that I could renew my certificate that has only 10 days left, but i got this error

2018-03-23 20:33:27,464:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/mydomain.com.conf produced an unexpected error: The requested apache plugin does not appear to be installed. Skipping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/mydomain.com/fullchain.pem (failure)
1 renew failure(s), 0 parse failure(s)

Can someone point me in the right direction to renew it
TIA


#2

What’s the version of your letsencrypt-auto?

./letsencrypt-auto --version

Also what is the contents of your /etc/letsencrypt/renewal/mydomain.com.conf file?


#3

Sorry for being so bad at linux i tried findind all ‘letsencrypt’ folders on the server
these are the find results:
find / -type d -name ‘letsencrypt’
/opt/eff.org/certbot/venv/lib/python2.7/site-packages/letsencrypt
/etc/letsencrypt
/usr/lib/python2.7/dist-packages/letsencrypt
/usr/share/doc/letsencrypt
/var/lib/letsencrypt
/var/log/letsencrypt

Can you please tell me what commnads shall i run to be able to find the info you need

on the .conf file - i tried sudo nano and here it is

# renew_before_expiry = 30 days

version = 0.20.0
archive_dir = /etc/letsencrypt/archive/mydomain.com
cert = /etc/letsencrypt/live/mydomain.com/cert.pem
privkey = /etc/letsencrypt/live/mydomain.com/privkey.pem
chain = /etc/letsencrypt/live/mydomain.com/chain.pem
fullchain = /etc/letsencrypt/live/mydomain.com/fullchain.pem

Options used in the renewal process

[renewalparams]
authenticator = apache
installer = apache
rsa_key_size = 4096
account = 136d7587e1cb3e3711391d31e073cff6
renew_hook = systemctl reload rabbitmq


#4

Can anyone help me out in here.
My certificate it’s about to expire, please!

TIA


#5

When you started this thread you would have been presented a form to fill out which streamlines the process as it asks the most common questions needed to diagnose issues. You did not fill it out.

Maybe you’d be best helped by starting at the beginning.


#6

@alento, a colleague said:

As for ways to work around it, I’d start by having them download a new copy of certbot-auto and try running that (without --no-self-upgrade).

Step after that would be deleting /opt/eff.org and trying again.


#7

Thanks schoen
that worked fine :rofl:


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.