Error trying to activate SSL for my new Wordpress website

I'm hosting a Droplet on DigitalOcean for my new Wordpress website.
I ran the Putty installer, connecting to my server by 'root' and 'password'. However, the SSL isn't installed successfully.

It produced this output:
Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Type: connection
Detail: [myip]: Fetching Domeinnaam overnemen? Koop nu en start met je plan. Timeout during co nnect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot wit h -v for more details.
WordPress has been enabled at [] Please open this URL in a browser to complete the setup of your site.
/root/ line 133: break: only meaningful in a for', while', or `until' loop
Finalizing installation...
--2023-06-08 15:38:29--
Resolving ( 2606:50c0:8000::154, 2606:50c0:8002::154, 2606:50c0:8001::154, ...
Connecting to (|2606:50c0:8000::154|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6928461 (6.6M) [application/octet-stream]
Saving to: ā€˜/usr/bin/wpā€™

My domain is parked at Namecheap and I have the Nameservers set to DigitalOcean's nameservers. So I added the domain to my DO droplet

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine (yes or no, or I don't know): I think we're referring to Putty here?

I would highly appreciate it if someone could quickly help me further, I haven't had this issue in the past.. I'm not sure what I'm doing wrong.

You've removed the "I ran this command" question for some reason. I'm not sure why, as it would be most helpful to know what you actually did to produce that weird output. It seems that Certbot is being run by some (dubious?) script. Would be most helpful what kind of script et cetera.


We are mostly unpaid volunteers here.
I, personally, would appreciate adequate patience.


Apologies. You're right. I've simply created a Droplet at DigitalOcean, selected Ubuntu as the OS and clicked the Wordpress app. Then I proceeded with installing PuTTy and then I connected to the 'root' and 'password' account which I created when I created the Droplet.

Then.. it follows an automatic procedure where it installs Wordpress, asks me if I want to install LetsEncrypt SSL.. and then I got that message. That's how it went.

No, it isn't installed because the request for the cert failed due to "Timeout during connect". This is usually a firewall blocking the validation attempt by the Let's Encrypt servers.

The script you used did not notice this error and continued trying to install WordPress

I can connect to your domain now using HTTP (port 80). And, the Let's Debug test site ( shows a good result too. Have you corrected something since your initial attempt? Because I don't see a reason why it would fail with a timeout.

Can you just retry your initial attempt?


Not sure if running that script again would be wise, but it might work. No clue, haven't got any experience with it.


By the way, this indicates a bug in the script that you ran. That might or might not have caused the error, but it is an actual programming logic/syntax error in that script.


Who provided that script, and where did you obtain it from, and how did you run it? I assume that you have to type some specific command when you ssh into your server with PuTTY, not just watch it perform tasks with no prompting?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.