Error on certificate Renewal

We’ve been experiencing expiry of the SSL sertificate we have on clients.nevilleco.com every 90 days. We’ve developed a CRON job to auto renew the certificate but I believe that may be failing. Due to the problem binding to Port 80. Any help would be amazing.

My domain is: clients.nevilleco.com

I ran this command: certbot renew

It produced this output:
-------------------------------------------------------------------------------
Processing /etc/letsencrypt/renewal/clients.nevilleco.com.conf
-------------------------------------------------------------------------------

Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator standalone, Installer None
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for clients.nevilleco.com
Cleaning up challenges
Attempting to renew cert (clients.nevilleco.com) from /etc/letsencrypt/renewal/clients.nevilleco.com.conf produced an unexpected error: Problem binding to port 80: Could not bind to IPv4 or IPv6.. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/clients.nevilleco.com/fullchain.pem (failure)

-------------------------------------------------------------------------------
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/clients.nevilleco.com/fullchain.pem (failure)
-------------------------------------------------------------------------------
1 renew failure(s), 0 parse failure(s)

My web server is (include version): Apache2 - not sure how to read the version but this is what’s output
LISTEN 0 128 :::443 :::* users:((“apache2”,pid=31651,fd=6),(“apache2”,pid=31650,fd=6),(“apache2”,pid=31649,fd=6),(“apache2”,pid=31648,fd=6),(“apache2”,pid=31647,fd=6),(“apache2”,pid=27213,fd=6),(“apache2”,pid=932,fd=6))
LISTEN 0 128 :::80 :::* users:((“apache2”,pid=31651,fd=4),(“apache2”,pid=31650,fd=4),(“apache2”,pid=31649,fd=4),(“apache2”,pid=31648,fd=4),(“apache2”,pid=31647,fd=4),(“apache2”,pid=27213,fd=4),(“apache2”,pid=932,fd=4))

The operating system my web server runs on is (include version): ??

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.19.0

1 Like

Hi @AndrewSepic

first: Your certbot is too old, 0.19 can’t work. Update or switch to another client.

Second: If you have the binding problem, a webserver is running. So use that webserver instead of --standalone.

PS: Acme-01 is deprecated. So an update is really required.

3 Likes

@JuergenAuer. Thanks for letting me know that certbot 0.19 is too old. I never would have known that. (Not having worked with it before).

Trying to run apt-get install --only-upgrade certbot causes an error

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

And running dpkg --configure -a ends up hanging forever on mySQL 5.7 install which never takes place. It seems like 251 packages on my install can be updated :expressionless: It’s highly likely I need to update and re-install everything to get certbot updated as well… I’ll circle back when I manage to get certbot updated!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.