Error: Let's Encrypt validation status 400

My domain is: VETERAN.FUN

I ran this command: VestaCP -> New web -> Domain: / IP: / Aliases: -> SSL -> Lets Encrypt Support

It produced this output: Error: Let's Encrypt validation status 400

My hosting provider, if applicable, is:

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): VestaCP

Hi. I have problem with create new certificate for my domain. If is there aliases is still error 400. How can i fix it?
I tried turning dnssec on and off, but to no avail.

I have only one record in DNS:
Type: A Record ; Host: @ ; Value: ; TTL: Automatic

And second question. How can i delete all others certificates after the create new one?

Thanks so much for the help and answer.

1 Like

Can you explain more about your problem?

Because I see you got many certs recently (see public logs here).

Although, your server is using a cert with a name Is that a different one of yours?


Hi @BA909, and welcome to the LE community forum :slight_smile:

I can't resolve that name to an IP.     nameserver =     nameserver =


*** UnKnown can't find Non-existent domain

Furthermore, there are DNS issues with both DNS servers; And some systems can't resolve either name.


Hi Rudy, greetings to Florida :palm_tree: :heart: and thanks for the answer.

I dont know why is that. :sob:
Everything is writen on Namacheap site but i don't understand it.

This is standard nameservers from Namecheap with a purchased domain. But if i change to Custom DNS then I can't add any host record. Only own nameserver. But my web hosting does not provide a nameserver, only a host record on address: and this is everything what i have from my web hosting.

it is described here:

I'm sad because I don't understand it and I don't know how to fix it.

Thanks again for help.

1 Like

Hi Mike, i dont have any others cert. I dont know what is :man_shrugging:

There are many because I tried it many times.

Thanks for help.

"add new record" for "www"


Are you sure that is your IP address then?

Because a site like this SSL Checker (here) says you are not using the right cert. SSL Labs reports the same failure (here)

The most likely reasons are that your server is configured wrong or that is not your IP address. But, you are getting certs so not likely a wrong IP

What kind of server do you run? (apache, nginx, other ...)


Now is OK?

And DNSSEC? Enable or Disable?

1 Like

Yes to both


Mike and rg305 thanks so much.

I finally have a certificate. :pray: :pray:

www record fixed that and I turned on DNSSEC.

And is there any way to delete the other certificates?


No. Public certificates are permanent.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.