Error during certificate install

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
http://portalservcon.com.br
I ran this command:
root@servcon:~# certbot certonly --webroot -w /usr/local/lsws/portalservcon.com.br/html/ -d portalservcon.com.br
It produced this output:
/usr/local/lsws/portalservcon.com.br/html/ does not exist or is not a directory
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/tmpnagmw7g6/log or re-run Certbot with -v for more details.

My web server is (include version):
Openlitespeed
The operating system my web server runs on is (include version):
Ubuntu 2204
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

How can I solve this?
Thanks
Leonardo

1 Like

I'm not sure how the error message:

Can be more clear?

The webroot path you've given as option does not exist or is not a directory.

1 Like

Hi @Osiris
This happened when I created the certificate with the command (certbot certonly --webroot -w /usr/local/lsws/portalservcon.com.br/html/ -d web.itzgeek.com). As I understand it, the path indicated in the command above is incorrect. I don't know what the correct one is. It seems simple to solve, but how?
I hope I've clarified things.
Thank you.

1 Like

You TRIED to create (get) a certificate, but the command was unsuccessful, so you haven't gotten a certificate yet.

That's indeed what the error message is telling us, yes.

I'm a little bit puzzled. Where does the path /usr/local/lsws/portalservcon.com.br/html/, which you used in the Certbot command, come from if you don't know what the value should be? That's something you've manually entered on the command line, right? It surely must have gotten from somewhere. But where?

2 Likes

I was following this tutorial on How to Configure Let's Encrypt SSL in OpenLiteSpeed Web Server. I took the command from there because I had already installed openlitespeed and just wanted to install the certificate. So much so that my http page is ok, it returns the openlitespeed page. How can I see the correct path via putty, what command should I use?

You didn't use that guide to install Certbot, right? Because it's terribly outdated. You should follow the instruction generator at https://certbot.eff.org/ to get the most recent version of Certbot.

It would be somewhere in the OpenLiteSpeed configuation. I don't have experience with OpenLiteSpeed, so cannot literally guide you to that information. You should have set the host root somewhere previously when you installed and set up OpenLiteSpeed.

2 Likes