Error after Lizenze agree


#1

An unexpected error occurred.
Error: unauthorized :: The client lacks sufficient authorization :: Error creating new authz :: Syntax error
Please see the logfiles in /var/log/letsencrypt for more details.

letsencrypt.log:
http://pastebin.com/3yAEVnr4

System:
Debian-80-jessie-64-minimal


#2

Thanks for the bug report @Tealk. As I’m assuming you’re aware, the problem is you asked for the name “bug” which isn’t a valid domain name. This is not being checked by the client and is causing the server to respond that there is a syntax error in the request.

The client should perform this check and give the user a friendlier error if a requested domain is invalid. I created #1054 for tracking the issue.


#3

Thank you for your answer,

i have select the Domain "anzahcloud.de"
but i have rename the domain “bug.anzahcloud.de” and try again and get the same error

letsencrypt.log:
http://pastebin.com/sqnUqCqh


#4

Looking at your logs, I see at the end of line 22:

... domains: ['root.anzahcloud.de', 'ts.anzahcraft.de', 'tsw.anzahcloud.de', 'gitlab.anzahcloud.de', 'www.anzahcloud.de', 'mysql.anzahcloud.de', 'paste.anzahcloud.de', 'youtrack.anzahcloud.de', 'anzahcloud.de', 'bug']

The problem is that “bug” is not a valid domain name. When you are prompted to give a comma/space delimited list of domain names, what are you entering? If the name you want is bug.anzahcloud.de, then that fully qualified domain name must be entered. Including only the subdomain “bug” won’t work. Also, make sure that you aren’t accidentally typing “bug,anzahcloud.de” (with a comma).


#6

ok i have fond this misstake :frowning: have set a “alias bug”

but now i geht the error
An unexpected error occurred.
Error: unauthorized :: The client lacks sufficient authorization :: Error creating new authz :: Syntax error
Please see the logfiles in /var/log/letsencrypt for more details.

letsencrypt.log:
http://pastebin.com/PuAGgdDK

i think it is the “Debian-80-jessie-64-minimal” but i dont know where this come from
domains: [‘root.anzahcloud.de’, ‘ts.anzahcraft.de’, ‘tsw.anzahcloud.de’, ‘gitlab.anzahcloud.de’, ‘Debian-80-jessie-64-minimal’, ‘www.anzahcloud.de’, ‘mysql.anzahcloud.de’, ‘bug.anzahcloud.de’, ‘paste.anzahcloud.de’, ‘anzahcloud.de’]


#7

Yep. It is almost certainly the “Debian-80-jessie-64-minimal”. One thing you can try is to add the -t or --text flag to the command line to use the client with a text based interface instead of the ncurses UI. This could potentially solve the strange I/O problems you’re having. This has the added benefit of you being able to pastebin the interaction between you and the client.


#8

with the -t flag:

Which names would you like to activate HTTPS for?

1: root.anzahcloud.de
2: ts.anzahcraft.de
3: tsw.anzahcloud.de
4: gitlab.anzahcloud.de
5: Debian-80-jessie-64-minimal
6: www.anzahcloud.de
7: mysql.anzahcloud.de
8: bug.anzahcloud.de
9: paste.anzahcloud.de
10: anzahcloud.de

Select the appropriate numbers separated by commas and/or spaces (Enter ‘c’ to
cancel):

as test, i have kick all .conf exept default.conf from sites-avaliable, but the Debian entry is still there

my default.conf
<VirtualHost 176.9.90.67:80>
ServerName root.anzahcloud.de
ServerAdmin tealk@anzahcraft.de
DocumentRoot /var/www/owncloud

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

so i still dont know where this entry come from

//Edit
but with the -t flag i was able to finish the prozess