Error at setup letsencrypt


#1

Hi!

I have this problem:

I want to start letsEncrypt. I have installed it via git on my debian VServer.
If I now type ./letsencrypt-auto it works so far. I see some text and than the Licence stuff.
After accapting I have to choose my domain.
I choose one and than get this error:

An unexpected error occurred. and `Error: unauthorized :: The client lacks sufficient authorization :: Error creating new authz :: Syntax error
Please see the logfiles in /var/log/letsencrypt for more details.

so here is my latest log file: http://hastebin.com/pidixucagi.sm

Do you maybe know what to do?
and is it right to install in /root ?

Faithfully yours Jan
`


#2

From your log:

2015-11-23 15:38:50,924:DEBUG:acme.client:Serialized JSON: {“identifier”: {“type”: “dns”, “value”: “*.istgay.tk”}, “resource”: “new-authz”}
[…]
2015-11-23 15:38:51,143:DEBUG:requests.packages.urllib3.connectionpool:“POST /acme/new-authz HTTP/1.1” 403 90
2015-11-23 15:38:51,145:DEBUG:root:Received <Response [403]>. Headers: {‘Content-Length’: ‘90’, ‘Expires’: ‘Mon, 23 Nov 2015 15:38:51 GMT’, ‘Server’: ‘nginx’, ‘Connection’: ‘close’, ‘Pragma’: ‘no-cache’, ‘Cache-Control’: ‘max-age=0, no-cache, no-store’, ‘Date’: ‘Mon, 23 Nov 2015 15:38:51 GMT’, ‘Content-Type’: ‘application/problem+json’, ‘Replay-Nonce’: ‘nzCT9ezX3LNki4iPedPOFqfaSjGiQ1CvMMXrxJHNZWo’}. Content: '{“type”:“urn:acme:error:unauthorized”,“detail”:“Error creating new authz :: Syntax error”}'
2015-11-23 15:38:51,146:DEBUG:acme.client:Storing nonce: '\x9f0\x93\xf5\xec\xd7\xdc\xb3d\x8b\x88\x8fy\xd3\xce\x16\xa7\xdaJ1\xa2CP\xaf0\xc5\xeb\xc4\x91\xcdej’
2015-11-23 15:38:51,147:DEBUG:acme.client:Received response <Response [403]> (headers: {‘Content-Length’: ‘90’, ‘Expires’: ‘Mon, 23 Nov 2015 15:38:51 GMT’, ‘Server’: ‘nginx’, ‘Connection’: ‘close’, ‘Pragma’: ‘no-cache’, ‘Cache-Control’: ‘max-age=0, no-cache, no-store’, ‘Date’: ‘Mon, 23 Nov 2015 15:38:51 GMT’, ‘Content-Type’: ‘application/problem+json’, ‘Replay-Nonce’: ‘nzCT9ezX3LNki4iPedPOFqfaSjGiQ1CvMMXrxJHNZWo’}): ‘{“type”:“urn:acme:error:unauthorized”,“detail”:“Error creating new authz :: Syntax error”}’

The client tries to request a certificate for a wildcard domain (*.istgay.tk). Wildcard domains are not supported by Let’s Encrypt. Removing that domain from your VHost or excluding it from the list of domains you request a certificate for should fix your issue.


#3

Thanks a lot!

Can you maybe tell me how to remove this domain?


#4

When you run letsencrypt-auto, you will be asked which domains you want to generate a certificate for. *.istgay.tk should be one of the options. Navigate to that domain using your arrow keys and deselect it with spacebar.


#5

Ahhh spacebar. :smiley:

Thank you a lot, you are awesome!