Error 429 Too May Requests

Hi! I'm new in this forum and in this kind of things. I realized a WebSite and I'm trying to install an SSL certificate from about 24 hours but the result is always the same.

Installazione di Let's Encrypt per non riuscita.
"" indicated an ACME error: 429 Too Many Requests (429 urn:ietf:params:acme:error:rateLimited (The request exceeds a rate limit) (Error creating new order :: too many certificates already issued for exact set of domains:, see Rate Limits - Let's Encrypt - Free SSL/TLS Certificates)).

I have got to explain that I moved my domain from an hosting to a new wone pointing to the new web servers about 60 hours ago. The mail server now is perfectly working, so I think that the propagation is ended with success.

The SiteGround help desk told me to try 1 attempt for each hour, but it seems to don't work and I don't trust them because I receive the same error from 24 hours ago.

it seems like they cannot help me. Is there someone who can help me to fix it?
Thanks for your answers.

My domain is:

I ran this command: No commands, using SiteGround interface

It produced this output: Attached before

My web server is (include version): Don't know

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: SiteGround

I can login to a root shell on my machine (yes or no, or I don't know): I don't kow

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Don't know

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Don't know

You've issued five identical certificates within the past week--why can't you use one of them?

1 Like

I don't know... I'm not very able about this things. I made a website with WordPress and the SiteGroud Help Desk use to assist me. 48 hours ago they told me to wait 24 hours. Same error. They told me to wait other 24 hours. Same error. Now they are telling me to wait other 24 hours. Maybe they are kidding me. They also told me that they cannot help me because Let's Encrypt is a third parties. That's why I am here. I think they are not very professional and I hope that someone could give me an hand to fix it. Have you got a solution for my issue? Thanks a lot.

You should be able to issue a new cert for your domains ( and at Jan 31 16:05:00 UTC.

1 Like

Thank you sahsanu! How can you be shure of it? Can you tell me how to check? I want to learn...


Let's Encrypt has a rate limit of 5 certificates covering the same sub set of domains per 7 days. If we check the certificates you have issued we got this:

CA  CERT TYPE   DOMAIN (CN)               KEY ALG      VALID FROM             VALID TO               EXPIRES IN  SANs
R3  Final cert      RSA 2048bit  2021-Jan-24 16:32 UTC  2021-Apr-24 16:32 UTC  83 days
R3  Final cert      RSA 2048bit  2021-Jan-24 16:22 UTC  2021-Apr-24 16:22 UTC  83 days
R3  Final cert      RSA 2048bit  2021-Jan-24 16:11 UTC  2021-Apr-24 16:11 UTC  83 days
R3  Final cert      RSA 2048bit  2021-Jan-24 15:56 UTC  2021-Apr-24 15:56 UTC  83 days
R3  Final cert      RSA 2048bit  2021-Jan-24 15:05 UTC  2021-Apr-24 15:05 UTC  83 days
R3  Final cert  RSA 2048bit  2020-Dec-17 21:07 UTC  2021-Mar-17 21:07 UTC  45 days

Note: You can check it yourself here |

So the last 5 certificates covering the same sub set of domains were issued at 2021-Jan-24, the first of those 5 certificates was issued at 2021-Jan-24 15:05 UTC, Let's Encrypt subtracts one hour to the date the cert is valid from (to avoid issues with misconfigured clocks) so the actual date is 2021-Jan-24 16:05 UTC then add 7 days to that date and you get 2021-Jan-31 16:05 UTC.


Thank you very much for this explanation. The SiteGround Help Desk is very unprepared about this topic and no one can give me precise and precious explanation like you did. This is very ridiculous because, if they use Let's Encrypt as a unique provider for SSL certificates, they should be able to tell theyr customers how to use it. For example, my issue was generated because someone in the SiteGround staff suggested me to install SSL certificate before the domain propagation, whith the result that my website have been offline for almost a week overall.

Leaving aside these stories, danb35 told before you made your invaluable contribution to this discussion:

Is there a way to retrieve old certificates and make them work with my website?

Consider that I'm a little bit familiar with Linux terminal, if this could be helpful.

Thanks a lot!


You can download the certificates from the page I pasted above but that is useless without the private key and you won't get it from any public site. If those 5 certificates (and their private keys) are in some place, SiteGround should know where they are, I don' know what client/process they use or what is the workflow to issue and install certificates in their platform so I can't advise you any solution to find them.

I'm afraid you should ask SiteGround support team or wait until 16:05 UTC (if you are in Italy 17:05 CET) and try again.


I contacted again SiteGround's Help Desk and threatened them to call my lawyer to ask for financial and reputational damages. At that point they solved the issue by doing something manually: after they kept telling me there was nothing they could do to help me (for 48 hours), the solution magically popped up.

It's really true... with calm you always solve everything. :wink:

Thank you sahsanu! Have a nice WE!


Hehehe :wink: I'm glad your site is up and running again.

And yes, they have used one of the issued certs, this one:

R3  Final cert      RSA 2048bit  2021-Jan-24 16:11 UTC  2021-Apr-24 16:11 UTC  83 days

Have a nice weekend you too!



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.