Error 429 - too many requests

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: Went to and requested SSL for the domain.

It produced this output: Error 429 for too many requests.

My web server is (include version): Easywp

The operating system my web server runs on is (include version):unknown

My hosting provider, if applicable, is: Namecheap

I can login to a root shell on my machine (yes or no, or I don’t know): i dont know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Hi @nathangiff

checking your domain there are no new certificates ( ):

Issuer not before not after Domain names LE-Duplicate next LE
Sectigo RSA Domain Validation Secure Server CA 2019-04-16 2019-07-16,
2 entries
Let's Encrypt Authority X3 2019-02-22 2019-05-23,
2 entries
Let's Encrypt Authority X3 2019-02-22 2019-05-23
1 entries

Only two older.

So this

must be the failed validation limit:

There is a Failed Validation limit of 5 failures per account, per hostname, per hour.

Looks like you are doing something wrong.

Perhaps share a screenshot how you create the validation file.

I wonder if sslforfree creates a new Let’s Encrypt account for every certificate request? Right now it seems not to be working for me either. That is likely to be a bug with the sslforfree site.

I have the same problem on sslfofree.
Unable to renew existing and unable to create new.
I wrote a letter to them. Waiting now…

Hi @Radius17

please read

and the two other topics.

It's a problem of Sslforfree, not of Letsencrypt.

Select your own client.

Hi @Radius17, @schoen, and @JuergenAuer,

We just switched off the RemoveWFE2AccountID functionality in production and are seeing issuance from sslforfree working as intended once again. Please also see the following topic ACME v2 - Scheduled removal of ID from account objects


Thanks, it works now.
And another questions appeared:
Is it a trouble on sslforfree ?
Its code does not support such behaviour of production ( ACME v2 - Scheduled removal of ID from account objects) ?

@Radius17 Yes that’s correct. Please see the following thread for more information. SSL For Free hitting rate limits

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.