Err_cert_date_invalid


#1

My domain is: api.cassette.rocks

I ran this command: ./certbot-auto renew

It produced this output:

Cert not yet due for renewal. The following certs are not due for renewal yet

with the file path to fullchaim.pem for api.cassette.rocks

However the certificate ran out yesterday.

My operating system is (include version): Ubuntu 14.04

My web server is (include version): nginx 1.4.6

My hosting provider, if applicable, is: AWS EC2

I can login to a root shell on my machine: yes

I’m using a control panel to manage my site: no


#2

You did get a valid certificate. Perhaps you’re just not using it. Did you try reloading nginx?

sudo service nginx reload

#3

Thanks, That’s fixed it! My cronjob must not be set up to restart nginx after the renewal - with a post hook?


#4

According to crt.sh you don’t seem to have any other certificates for that domain besides the original one and the new one, so I’d guess your cronjob isn’t set up or isn’t working at all (as it should have renewed when the cert was a month from expiry). It should look something like

43 21 * * * /path/to/certbot-auto renew --quiet --no-self-upgrade --post-hook="service nginx reload"

and of course it should be in root’s crontab as it won’t be able to ask for your password if you run it under your own account.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.