Epired ssl autossl not working

I just did autossl to my website "WordPress websites" and it was successful but when I try to open my site from any browser it says your connection isn't private.
and that's not the only site I'm having trouble with there is one more.
and SSL is issued by Cpanel. the only domain that is secure is the Cpanel domain www.example.com:2083 and WordPress Cpanel domain.

My domain is:

My web server is (include version):
nginx server

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
cPanel 100.0.5

Note:"I'm new to Cpanel and these kind of stuff"

You're currently posting on the Let's Encrypt Community forum, but your certificates are not issued by the Let's Encrypt CA. See here: crt.sh | sma-news.net

My recommendation is to contact your hosting provider about your issue.

Edit: Also, I'm genuinly curious: why did you remove almost all the questions from the questionnaire?


how can I issue the cert of yours instead.

about your questions they looked like messed up lines so I deleted them

That might also depend on your hosting provider. However, you haven't provided us with that information. I recommend to contact your hosting provider about that too.

Not sure how these lines look 'messed up' to me though:

I ran this command:

It produced this output:

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Look like perfectly normal lines to me personally.


my hosting provider is HostDime.com

ok sorry I thought they were messed up but I didn't know

I'm not sure you can switch to Let's Encrypt. HostDime doesn't say anything about Let's Encrypt on their knowledge base (Installing a Free SSL via the cPanel AutoSSL Feature - HostDime Knowledge Base), only certs from cPanel.

Also, what's wrong with the current certificate?


Looks like you issued a new cPanel cert today. But, your server is not sending it. You may need to restart your server or somehow apply the new cert. I am not familiar with HostDime so ask them how if you are not sure.

And, you issued one in Dec too but your site is using the one created Oct6 - see here

Looks like you need to work with HostDime to figure out how to keep their certs current


I really don't know I did the AutoSSL and it seemed to be successful but when I open my website as if no SSL was installed.

That could also be due to a missing HTTP to HTTPS redirect for example. Or perhaps you need to associate the certificate with your site first for HTTPS to work, I dunno. See your hosting providers knowledge base for more info. I don't think switching to Let's Encrypt will fix anything related to such things, as it will only change the certificate authority which is issuing the certificate. It won't magically fix incorrect settings at the webservers part.

Also, currently your entire site is down. Not related to SSL. HTTP is down too.


Thank you guys for all your help I really appreciate it. the problem is solved turned out to be server-end issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.