Echec de la connexion à Let's Encrypt. Assurez-vous que le nom de domaine est valide

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: crosland.myds.me
Other domains are : crosland.ddns.net and crosland.eu (this one is a redirection from 1&1 hosting service).

I ran this command: I use the Synology configuration tool: Control Panel, then Security, then Certificate.

It produced this output: “Echec de la connexion à Let’s Encrypt. Assurez-vous que le nom de domaine est valide.”

My web server is (include version): Apache2

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: I use DDNS (Synology).

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, the Synology one.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Yesterday, I felt into another error : “too many certificates already issued …”
I was trying to renew my certificate alreday installed on this Synology server. Today, I did not get this error (up to now!).
Thank you in advance for you help.

1 Like

Hi @Pierre55

please read the link shared in the error message.

1 Like

Hello Juergen,

Actually, this error did not appear today. Yesterday, I read the explanation from the forum related to this error, and, I decided to give up for the day, and to try again later. So did I.
But, today, I still cannot renew the certificat which was automatically renewed for the last months. The message refers to a wrong domain name, so, I am confused!
Thanks again and best regards, Pierre.

What’s the exact error message?

Checking the three domains

there are only timeouts -> http validation can’t work.

1 Like

Juergen,

Actually, I am able to connect to “https://crosland.ddns.net” !
But, it is correct for “https://crosland.eu”. It seems not to be online while it should be ok as I can see on “1 and 1” web site.

But, I realized that there is one URL that cannot answer anymore : “https://crosland.dyndns.org”. It is refered in the existing certificat. How can I change this setting, I mean, how can I remove this URL from the certificate?
Do I have to remove the existing one and ask for a new one?
The exact message is in the title (but in french!), so here it is in english : “Connexion to Let’s Encrypt failed. Make sure the domaine name is valid”. So, that could refer to the additional domain name “https://crosland.dyndns.org”.
Thanl you again for your help!
Pierre.

I don’t know, I don’t use that Synology client.

There must be an option to remove that domain name -> then create a new certificate without that not working domain name.

1 Like

Juergen,

I change the default certificate for this server then I was able to remove the certificate issued by “Let’s Encrypt”.
Then I requested a new one, and that worked but without any of the two aliases I expected to add.
In any case, it worked!
So, for me, this issue is solved.
Manu thanks for your help and best regards, Pierre.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.