Don't see Domain's

Hey
I installed Certbot normally, but now only see one domain. I am using nginx. I would like to include other domains in the certificate

Yours sincerely
Sven

2 Likes

Hi @D0ppe1gaenger

then your nginx config is buggy.

What says

nginx -T
2 Likes

Also, there should have been a questionnaire presented to you when you opened this thread in the #Help section. Maybe you've deleted it, maybe it wasn't presented to you for some reason. But in any case, we really want as much answers to those question as possible to help you the best. If you don't know the answer, please say so at the place where the answer would be:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

2 Likes

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

2 Likes

I think @JuergenAuer wants the output of:

sudo nginx -T

1 Like

Here: root@v2202007122499122510:~# sudo nginx -Tnginx: the configuration file /etc/n - Pastebin.com

1 Like

With your output, that's

expected.

There exists no

server {

}

with port 80 and a domain name.

Additional domains -> additional definitions are required.

1 Like

Ich weiss gerade nicht auf was du aus willst. Hab gesehen, dass du deutscher bist.

@JuergenAuer

I do see a port 80 server block with the correct server_name on line 256.

I see two sets of SSL options though:

  • inside the http block that includes TLSv1 and TLSv1.1 (and yet not TLSv1.3) in ssl_protocols on line 42
  • outside (not in any block) that appears to come from /etc/letsencrypt/options-ssl-nginx.conf that has correct ssl_protocols on line 272.

I'm not sure how these conflicting settings will be prioritized.

As for the "missing domains" I don't see any indication of any other domains. Not active maybe?

1 Like